Z travel

Im almost ready to cut the struts for my LR3 but ive got some issues with Z.
If i home with Repetier host and then manually run Z 10 mm down it will move about 50 mm first time.
If i give the same command again (10mm) it moves 5 mm down here on after.

I have changed steps per mm to 200 for Z to keep it from crashing when i give the first command.
For X and Y 100 and 50 seems to be right.

Can someone explain what im doing wrong?

I use SKR Pro V1.2.

Thanks, Jörgen

To get the best chance of helping, could you post some photos of your setup, and give more details on it? I have no answers right now, but a lot of very knowledgeable, bright people are on here and odds are good of getting to the cause of the issue.

Are you running headless, or do you have a TFT connected?

If you have a TFT, does the same problem happen if giving commands that way?

If you don’t have a TFT, are there any other control interfaces you could try to see if the problem is repeatable? Pronterface?

I Will get some photos but its a basic LR3 with SKR PRO 1.2 and TFT 35.
Before i read your answer i used Repetier host in a laptop connected by USB.
I switched to headless mode and gave it instructions to move Z -10 mm. It starten to go up and down several times and for every time it went down it went a little bit further. It would have crashed if i hadnt pulled the plug.
I noticed one more thing. When i enter the movement menu, the x motors move a little and irregular all the time.

Thanks, Jörgen

I don’t know if this could be a wiring issue, but perhaps.

There is a way to rule out it being a driver issue, by swapping which wires are connected to which drivers, and if the problem follows the wires instead of remaining with the driver, it helps by process of elimination to get to the cause.

Photos of your board, connections, wiring, etc will help. Video of the problem in action will probably help.

I have had the exact same issue, running the same setup it seems. You need to run z home first and it’s not G28 Z which will give you the Z axis at 200 and be wonky.

I have a probe, if you don’t then you need to get your z to the board and then set it to 0
Here is the GCODE I use to do it with the probe
M0 Attach probe
G38.2 Z0
M0 Remove probe
G92 Z0.5
G1 Z15 F900

G38.2 Z0 tells your lowrider to go to z0 but only until the probe is made contact then it understands that’s 0

G92 Z0.5 tells it to set the Z axis at .5mm above the cutting surface, somtimes when my GCODE isn’t set to this I just set this to G92 Z0

If you don’t have a probe you can run G92 Z0 from the top then run small commands like G1 Z-5 or G1 Z-10 to get it close then even smaller to get it to the board

Thanks Jeff, im gonna get a probe and try! :+1:
Can you explain this?

There was another reply here, Im gonna try and see what happens.

However, i noticed that if Im in the move menu and choose for example Z axis, it starts to move front and back just like 0.1 mm and so.
Same happens if i choose another axis. The selected axis starts to vibrate in the same way.
I made a video but i seems like i cant upload it.

I also don’t understand this statement. For Marlin, “G28” will home all axes, and “G28 Z” should indeed home only the Z axis.

On a LowRider, the Z axis homes to Z max, and that should not be wonky.

The considerable issues that @JW1 described, won’t be solved by merely getting a touchplate. The issues need addressed, worked out, and solved. Should not be moving 50 mm when 10 mm was commanded, or be moving 5 mm when 10 mm was commanded. Should not need to drastically alter e-steps to get correct movement, especially when it is to fix the over movement while then causing under movement at all other times. Also, the jitter he described, moving back and forth on any axis when that was not commanded, should not be happening. ??

Even though Jeffs answer is going to help me your offcourse right. The problem with the jitter is there.

I dont know if its a related fault but if the machine is in home position and i break the power, on of the z motors just let go and the machine falls down in that side.

Process of elimination is allways good, right now i just dont have any idea of where to begin?

Steps per mm should be derived from the pitch of the leadscrew and the number of steps (or microsteps) per revolution, not to keep the machine from hitting a limit.

1 Like

A well lubed and properly aligned LowRider will have its gantry drop on the Z axis without power. A lot of guys use blocks under it when shutting down, so it lands on the blocks.

Sometimes when the core is on one side or the other, only the side with the weight of the core will drop. Usually on mine, if the core is positioned in the middle before powering off, both my sides will drop.

If you swap the wires from X or Y stepper to the Z driver, and swap the wires from Z stepper to X or Y driver, you could test wiring on “new” driver. Bear in mind the steps are quite different between Z and the others.

Thats a thought but all motors behave the same.
I Wonder if its a current issue?
I soldered extensions on the stepper wires. I noticed that they where quite thin.

If not all steppers are doing the thing of moving 50 mm when you told it to move 10, then the swap may be helpful.

G28 does home, but on repetier it seems to no matter what tell you there is 200MM of Z travel, the only way I’ve been able to get that right is setting Z and going from there

Also when I stated wonky, I didn’t mean the machine, I mean the commands that it was getting from Repeteir, it seems like when you home the machine with simple G28, and run any Z command it doesn’t send the LowRider the correct GCode, I have had it where I sent it down 1mm from the TFT and G01 Z-1 from Repetier and it just kept going driving into the table doing a wheelie.

I am assuming there is a problem with the repetier setup, or my setup of it anyway.

I cannot be certain, but this may be a case of move commands while in either gcode mode of g90 or g91, while expecting the other mode.

If you google “gcode g90 vs g91” you get a quick help note that says it this way:

These G codes change the way the axis commands are interpreted. Axes commands following a G90 will move the axes to the machine coordinate. Axes commands following a G91 will move the axis that distance from the current point .

Put another way, if you are in G90 mode, and you give a command to go Z -1, you are saying to go to the machine coordinate of Z = -1, not telling the machine to move down -1 from where it is currently.

Come to think of it, this business of G90 versus G91, may explain why @JW1 was having strange results with using Repetier host.

@JW1 can you confirm which of the two modes you were in, and that you were tracking the difference between “absolute coordinate” commands versus “relative to where the machine is now” commands?

NOTE: I have not ever used Repetier host, and so I may be off base, but it’s worth mentioning.

1 Like

Thankyou all for now, got some homework to do. Ill get back here. Just curious, what is the default settings regarding steps per mm for the LR3 using the V1E recommended parts?

I’m pretty sure my lead screws are the same type as the V1E recommended parts, and my Z steps/mm are set to 200.

About the jittering which i found mist disturbing.
The facts… Headless mode…

  • It starts when in the ”Move” menu.
  • Only the selected axle jitters.
  • If i change how much i want it to move from 0.1 mm which is default in headless mode to 1 or 10 mm the jittering become proportionally larger. It goes from jitter to moving front and back.