Z Leveling in the Y max

I have my Z leveld within .2mm between y0 x0 and y0 x1220. But when I move to y1220 x0 or y1220 x1220 im off again by +2mm. Is the solution to re surface the spoilboard or is there a way to adjust this in the settings?

That sounds like the spoilboard is not even and goes down in the back, I’d resurface it.

Thanks and that is what I thought. I just wasn’t sure if there was a setting that could be done in the software. It’s actually moving up in the back and that may mike the surface a little bit more tricky as I don’t want to remove anything from the front