Y-axis stop working during usage - Estlcam + cnc-shield


need help by a strange phanomenom using Primo built with Estlcam and cnc-shield:

I use my new Primo built as in the guides but during driving the y-axis, it suddenly stopped working and will not resume. Both other axis still operational, but the y-axis does not. After I switch cables back and forth at some point it work again, but I was not able to realize what /where the problem is.

Anyone encounter that also? Any ideas?

Thank you,

Do the motors hold their spot when they freeze, or can you move them without resistance?
Does it do it for any project you try to run, or is it only one specific project?

You may have a bad cable/connection somewhere.


sorry for the very late feedback due to business trips and other topics I try to revisit my built again…

Unfortunately, Its still not working.
It sometimes work and then suddenly it stops; it may be better if I restart the computer but the latest 2 times I tried to use the Primo, suddenly in between the machine will go rogue and does weird things like go down as deep as possible or wil go way outside the mill area…

Could this all be attributed to cables? I mean, when I touch the cable connection, I get “feedback” from the steppers, so could they in a job “loose” their position?

Is there a possibility that this could be usb attributed?

As is now, I cannot use it, so I need help obviously :wink:

(Will start also another topic in troubleshooting)

I’m 99.9% certain you have an intermittent connection somewhere in your motor wiring. The .1% uncertainty I allow for comes from an understanding that manufacturing defects like bad solder joints are possible, but they are pretty rare. And they mostly don’t show symptoms that come and go like you describe.

If it worked at some point, stopped working, then started again without changes to the firmware or config settings saved to eeprom memory on the controller, this points to a hardware (rather than firmware or configuration) problem. Since the steppers themselves still move and react to commands sometimes, that points to intermittent. Since parts are soldered to the board, and assuming your board is fixed in place and doesn’t have manufacturing defects or anything shorting connections, that intermittent issue must be in the wiring, either right at the board (wrong connector on cable doesn’t really seat in the board connector), or somewhere between the board and the motor.

There are documented examples of motor extensions from the V1 shop having bad crimps, where the connector is pinched (or partly pinched) to the insulation rather than the conductor. I know I’ve made bad crimps when building my own extensions/harnesses. Close visual examination will reveal these, but you need to get the pin or socket out of the plastic connector body.

All my motors (for 3d printers as well as my MPCNC Burly) that use extensions get the connectors taped together at assembly, but even then tape can slip. Sockets and pins can slip in connectors so that things work when the wire is flat but lose connection when flexed (or vise versa).

Steppers don’t “know” their position. They take 1 step (or micro step) when the driver sends a pulse. If their behavior changes when touching the wiring, something is interfering with the pulses. Again points to problem in the wiring.

Take a methodical approach to inspecting each step in your wiring where a connection is made and I’ll bet you find your problem.

Hallo ttraband,

and thank you for your extensive answer. I started to look into the cables, but I am unsure, if I see the correct wiring…
I made the prolongations for the stepper myself and at least one seem to be good, but I do not see a difference in the wiring / connection in the dupont connector to the bad ones…

When I touch some cable connector I get “feedback” from the stepper with a “tak tak tak” sound; I assume that this attributes to the slip in the connector, not having contact all the times…
Is there a better way to do the connections (I could solder them) or could this be a bad batch of dupont connectors??

Thank you

I’ve never experienced the “feedback” sound you’re describing. Any chance you could capture it on a video and post a link?

Photos of the connections you made might help as well. The dupont pins have 2 areas where they should crimp closed. The larger one near the cable should just grip the insulation (serves as strain relief), then the smaller one nearer to the pin/socket end should enclose all the strands from inside the wire (making the actual conductive connection). Common errors I’ve seen (and made myself) include:

  • Not catching the insulation in the “outer” crimp - leads to easily broken wiring connection once things start to flex
  • Catching the insulation in/under the “inner” crimp - here again, flexing connections come and go
  • Removing strands when stripping the outer insulation - weak connections
  • Loose strand “whiskers” - can lead to shorts between connectors
  • Pins or sockets sliding back in the plastic connectors, especially after pulling and reinserting them a couple of times - can lead to loose, intermittent, or completely missed connections even if the plastic connectors but right up to each other.

Some of these are tough to catch, even with a magnifier. I’ve had dodgy connections that I couldn’t see any troubles with, but once I remade the ends everything worked fine. For this reason, I always try to build in a little extra length on any wire I’m making myself, so I’ve got room to redo connections if/when needed.

Of course, it’s also possible there’s a break (or short) in one or more of the conductors in the cable not anywhere near the connectors. Can you connect a tester (multimeter continuity, test light, etc.) and try moving the machine through it’s full range of motion? Look for places that have to flex when the continuity is lost on the wire.

Finally, are the connections at the control board put under any strain, perhaps from an enclosure door or lid?

Thank you Tom again for the extensive answer!

I throw away all of my self-made cables and made dry runs with the short cables connected on the stepper and all is working without stops or problems.

Seems to be my crappy cable making…
I bought now cables which will arrive next week and hopefully can do tests with real cutting.
I appreciate your advice on the cables, but for now I think I will try to get the MPCNC working and maybe in the future I will try to do cables again. But the experience that all (!) my cables I did were crab made me think I should stick to things I do better :wink:

Will let you know what happens next week!
Thank you

Crimping DuPont connectors definitely has a learning curve, and good tools make a huge difference. There’s a great topic here on the forums that helped me get better. Try searching for “what a game changer.”

You might be referring to this thread. I made a video a d several people offered good (maybe better) alternatives. There is a game changer comment in it, but I’m not sure which method it is referring to.