Y axis is off by a few mm

So I (nearly) finished building the Lowrider v3 without too much trouble.
( I also built an MPCNC like a year ago )

The only problem left is cutting the final strut plates … but for some reason they always come out 5mm short and don’t fit !?!

So here is what I know:

  • I bought the hardware kit from V1Engineering, so the belts and pulleys are the correct ones and the steps_per_mm in the Jackpot Controller are set correctly
  • the axes are squared within a margin of less than 1mm
  • the error is only on the Y axis
  • the error increases the longer the travel ( so is not an offset problem )
  • reducing the tension of the Y axis belts doesn’t solve the problem
  • the SVG is correct and the tool path is going around the outer border
  • the cut looks right … I mean, is not like it’s just wrong on one side

Not sure what else I could check ?

I did not try to set a different value for the steps_per_mm because I should not have to.

Any suggestions ?

Grub screws???!!!

Skipping steps due to binding in the Y travel path?

I doubted that it could be an issue with the grub screws as the cuts were perfectly square… but I checked anyway, and they were fine.

I stated that I tried to loosen the Y-belts … but of course, when the cuts are too short, I should tighten them … so I did … but no luck.

Then I tightened them even more … and now my cuts were a bit better !?
At this point, the belts were already tighter than what I think they should be.
But as my cuts were still too short, I tightened even more until my cuts were more or less correct.

I was pretty sure that this is not normal ! but it showed that the problem seemed to come from the belts:

So I ordered new ones… and now, the cuts are perfect, without over tightening.
Bad belt quality from V1Engeneering ?

… anyway, happy to have solved the problem !