X Tensioner on the Low Rider V3

Hi guys,
I’m plugging away getting my low rider running.

My latest issue that I can’t work out is the X tensioner. The nut that goes inside rotates when trying to tighten. After supergluing it in, the whole printed piece snaps easily along the line shown.

Tried twice, 30% infill as recommended, then 60%.

Any advice? Cheers

1 Like

Hello @juicyjesus! Welcome!

Nut spin doesn’t sound good, mine were tight fit, so tight I had to use pliers to push the nut in for some parts. What filament, printer and settings are you using? Used Overture PLA on Ender 3 Max, 0.6mm nozzle, 0.32 layer height. I used infill % recommended in LR3 Docs plus additional 10%

https://teachingtechyt.github.io/calibration.html helped me calibrate dimension accuracy, flow, temperature, speeds and the million other settings required to find a sweet spot to print parts.

Printed bunch of calibration cubes and test temperature tower and test retraction towers before printing LR3 parts.

Only tensioned belts with ~7lbs of pressure, hard to gauge, but it’s less tension than what I first thought would be required. Forum search for recommended belt tension may help too.

Replied to your other thread.

My Z motor can’t push all the way up. When the X core is on the opposite side the issue is then on the other motor.

Another thing I’d like to fix is homing the X axis.
My X axis is approx 1400mm, and the homing times out before reaching the end.
Is there a line in the firmwire I can edit to make it home over a longer distance?

Doesn’t look like you are hitting the endstop.
Did you run a M119? Are all endstops Triggering?
After confirming that all endstops are working, has 2 things you can do, bend the metal blade of your endstop or tread a screw to the XZ plate right where the endstop shoud be hitting.

Change the size at this line to the size of your machine.

// The size of the printable area
#define X_BED_SIZE 200 
#define Y_BED_SIZE 200

I would take the leadscrew out and make sure it freely moves all the way up, super smooth. (verify the linear guide position/parallel). If that checks out put the leadscrew back and assure there is no binding there either (Should be very rare at the top).

Yeah, the plates are hand cut. I was worried it wouldn’t be parallel.
Maybe I’ll cut the plates with a single Z endstop, and reassemble.

1 Like

Just give them a test, there is a bit of wiggle room for adjustment.

When I look at the firmwire, it says

#define X_BED_SIZE 600 // 200
#define Y_BED_SIZE 600 // 200

If I want 1400x2600 do I change just the 600,
#define X_BED_SIZE 1400 // 200

or replace the 600 // 200?
#define X_BED_SIZE 1400

The best way to do it is to home your machine and move the tool head to the X max and Y max.
Record the values and then change the firmware to those values.

Marlin will see // as a comment and will ignore what ever is after it.
The 200 that you see in there is the original default value from marlin that I believe has been commented by V1.
So it is up to you if you want to keep the old value as a reference.
Every time I edit marlin, I add //GP at the end of the line. It makes it easier to search for any editing (mistake) I made to the firmware.


I downloaded marlin from the lowrider document, I have changed the x, y and z measurements and tried to verify.

I keep getting errors.

I have changed the board setting to Rambo and Arduino Mega
I have added the U8glib library to the code.

What am I missing?

Arduino: 1.8.13 (Windows 10), Board: “Arduino Mega or Mega 2560, ATmega2560 (Mega 2560)”

In file included from sketch\src\lcd\extui\ftdi_eve_touch_ui\language\language.h:23:0,

             from sketch\src\lcd\extui\ftdi_eve_touch_ui\language\language.cpp:25:

sketch\src\lcd\extui\ftdi_eve_touch_ui\language\language_en.h:148:24: error: redefinition of ‘const char Language_en::MSG_MESH_VIEW []’

PROGMEM Language_Str MSG_MESH_VIEW = u8"View Mesh";


In file included from c:\users\aden~1.mor\appdata\local\temp\arduino_build_720275\sketch\src\core\language.h:563:0,

             from c:\users\aden~1.mor\appdata\local\temp\arduino_build_720275\sketch\src\inc/MarlinConfig.h:53,

             from c:\users\aden~1.mor\appdata\local\temp\arduino_build_720275\sketch\src\marlincore.h:24,

             from sketch\src\lcd\extui\ftdi_eve_touch_ui\language\language.cpp:23:

c:\users\aden~1.mor\appdata\local\temp\arduino_build_720275\sketch\src\lcd\language\language_en.h:160:8: note: ‘const char Language_en::MSG_MESH_VIEW [10]’ previously defined here

LSTR MSG_MESH_VIEW = _UxGT(“View Mesh”);


exit status 1

Error compiling for board Arduino Mega or Mega 2560.

This report would have more information with
“Show verbose output during compilation”
option enabled in File → Preferences.

You can’t build with arduino anymore. At least not in windows. You need to use platformio.

The firmware at MarlinBuilder releases has to build (or it won’t create the .zip). I would suggest building it as is before changing anything. If you can’t get the firmware to build with no changes, then it is a tools problem. If that works, the. You have a working tool and you can change 1 small thing at a time until you have what you want.


Thanks Jeff, moving to platformio worked. My lowrider now homes over a long x axis.
However now when homing Y, only one side moves. When manually moving, both sides move. Only when homing.
I’ve looked through the config and adv config files to try and see anything to do with homing, but haven’t been able to work it out.
Any ideas? Thanks

Check the endstops with M119 first. They should show which endstops are triggered. Make sure you have the right endstop with the right motor. Y2 endstop on Y1 motor makes it get weird.

1 Like

Everything was working as intended until I changed the firmware to edit the bed size. Now the second Y motor only moves back a step or few as the other homes.

I unplugged everything, and tested the motor with endstop in multiple places, but same thing.

I do think it’s something in my firmware. Is there somewhere that tells it to move E0 during Y homing?

Check with M119. Make sure there is a Y2 endstop and it isn’t triggered.

Hey Was there a solution to prevent that problem you were having ? I have an issue but it’s the belt that I cannot get to go though

Try cutting it to a point, feed it in, and use the other belt to pull it through.

Other than that your print looks very odd. Did you print it in the orientation I uploaded them in?

Looks like you printed it laying down and the print failed.

1 Like