X Skipping Steps

X is skipping steps after going smoothly for 300-350mm.

Ok some back story… Since building my LR3 ive had intermitten issues with homing Z that was guestimated by many to be an issue with the SKR pro needing pull up resistors on the end stops. Well i just so happened to have a brand new SKR pro here waiting to be installed in my MP3DP V4 (Currently under construction) so i decided that since i was going to be better off pulling the board to install the resistors that i would just swap the boards and keep the LR3 running. Installed the new board, Put V1 firmware on it. Tripple checked everything. Homes good. moves good. Everything good. Well i go to cut out a drawer side for some Drawers im making for the LR3 table. starts out good then after cutting along the X starts skipping steps. has happened 3 consecutive times now. All around the same distance. Its not an issue with the gantry as ive had to move around on the plywood so its all been in different spots yet all at around the same distance of cut. Ive slowed down my feed rate and it makes no difference. Ive checked all my wiring and its good. What am i missing??? im at a complete loss as of what to check next. Attached is my gcode for the cut thats messing up.

5in Drawer Side.gcode (2.8 KB)

Same distance, or same position on the gantry?

If problem always happens at same gantry position, am curious whether Vac hose, wiring, zipties/velcro or something is catching? Asking because I ran into stuff snagging/catching during drag race tests, which would translate to skipped steps.

If problem always happens for same distance regardless of start position, curious what your chips look like? Able to share your cut profile (feed, doc, etc…)?

12V or 24V power supply?

1 Like

The common reason for this kind of slippage is loose grub screws in the pulley. I also noticed in your g-code that your travel feedrate is 3000. This is significantly above Ryan’s suggestion of 2100.

1 Like

24v power Supply. 1/8" Compression bit. 6.5mm DOC 12mm/s (have been running at 15-20mm/s no problems since built) I will get a pic of the cuts and post.

It has no problems at travel. And it has no problem cutting until it starts skipping. Its not loose grub screws that i am extremely confident in.

Well….I think I figured it out… and I feel like a DA. Running it again right now at half speed and it’s making it but barely. I’m 99.9% sure this bit is toast. Hopefully it will finish this one. Have a brand new one on stand by and will be cutting another right after.

Was the wood burning, too much rubbing from high speed?

I know nothing about compression bits beyond a quick look on youtube. Curious what compression bit and profile you end up liking.

1 Like

I cut a lot of plywood and like that they leave a clean finish on both sides. I just have to remember to throw an old one away when it’s getting dull lol. Seems I must have used the last good bit of that one before I went to work. And 2 weeks away I sure didn’t remember that. Have a new one in now and it’s cutting like it should!


I’ve just had the same problem but with an LR2 and I think it’s the same reason…dull bit.
But does anyone know why this would be an X-axis issue and not have the same problem in Y? Ply doesn’t have a dominant orientation I think, although both outside layers are oriented in Y for this cut.
Is this because X only has one stepper motor and Y has two?

It could just be that the Y has two steppers. The Y has to do more work when just accelerating the gantry, but the bit load is higher per motor on X.

1 Like

Same thinking then.
@jeffeb3 you’ve talked about slow and deep cuts in the past.
At 6.4mm deep the cuts were working fine at 15mms. I upped it to 25mms to test and got the skipping in X.
Then I ran another part cut back at 15mms and noticed some scorching at the entry points so I slowed the rpm a bit. Then got more skipping. So I think the bit is gone but again all skips in X.
Anyways…live and learn and buy more ply.