Workpiece doesn't appear in grblcontrol, using Gcode generated by both Fusion 360 and Solidworks

Hello, It has been so many topics that I posted here, now I’m almost reaching final step. however I’m having the problem as I import Gcode file generated by both Solidworks and Fusion 360(as NC file), for some reasons only small green point appears as shown in picture. I have tried another method by import STL file to covertion website to generate GCode, but it doesn’t satisfy what I want, so I’m hoping an advice from this forum again.

Thank you in advance.

I don’t have an answer to your question, but uploading your g-code file in a post might help someone on the forum figure out what is going on. In addition, you might try a g-code simulator to see if it displays something different than the preview window of grblcontrol. Or, you could try dry running your job to see what happens. Put the tip of your bit well above your work surface and try running the job with the router turned off.

Is it possible you have the gcode units set to inches? That would make them 25x smaller than it should be.


“Serial port error 1: No such file or directory” and “Status: Not connected” are probably clues.

Is it possible that you drew in the wrong view in fusion? The same thing happens in Rhinceros when I accidentally draw in the frontview. Rotating to topview solves the problem for me.