Any WLED experts in here?

I am using the web installer (install.wled.me) to flash WLED onto my ESP8266 as described in this video.

When I plug in my ESP8266 it is recognized in the COM ports and I can select it in the list of devices from the web installer.

I select my device, which is COM6 (CP2102 USB to UART Bridge Controller) and select connect.

Then I get this message…


Has anyone had experience with this issue? I have spent hours researching this and cannot find a clear cut answer. I have not been able to figure out why it is saying the COM Port is being used by another application.

Don’t know, but have you seen https://wled.discourse.group? I discovered wled discourse forum thanks to this v1e forum.

I have never gotten the web installer to work, and it sounds more like a windows issue than a wled one. Are you using chrome?

I did come across the forums, but there is no answer to this issue there unfortunately.

I am using Chrome. I have used 3 different Windows computers and have used both Chrome and Microsoft Edge. I have also used 3 different ESP8266 boards and multiple USB cables. I believe I have ruled everything out to say that it is either a Windows issue or the web installer itself.

How are you flashing your board? Do you have a link to any instructions to follow?

I haven’t had problems using the web installer specifically, but I have run in to situations where other programs are using the port when I go to flash. In my case it’s usually obvious… like putty is opened and connected, I close putty, and it works. If there is some “phantom” process reserving the serial port, it may require more work to find it and shut it down. Some quick googling brought up this info that may help with that task:

Ooh, just recognized the ni.com url… legit stuff, I haven’t played their hardware since college though, lol.


+1, I’d try Process Explorer as well, e.g.
vb.net - How do I determine which process is using a serial port? - Stack Overflow

1 Like

Thank you for the help guys! I was able to successfully flash WLED using ESPHome-Flasher which worked great. Very simple process for that.

As far as the web installer goes, I may revisit this and explore the Process Explorer solution.

1 Like

I’ve had great many issues with wled not running led-strips properly - but never with flashing! :smiley: the web-installer has worked great for me. Sorry if that wasn’t much help… Only issue was finding the correct usb cables and adapters, going from usb-c to other usb variants. That can sometimes be quite annoying, never know if its the cable, adapter or controller that is bugged…


Yeah now that I have it flashed and working, I am running into another issue with it. After a while, it seems to reset and go back its default orange static lighting no matter what color or effect I had it on. I am wondering if its a current issue. I have a 12V 6A power supply running the ESP8266 and the lights (191 leds) and I would think that would be plenty of power.

I have the same issue with some of my WLED setups. I would definitely check out the WLED Discourse form like @azab2c mentioned. Lots of good help there.

191*60mA = 11.5A.

The WLED config should be able to limit the total current. Make sure you have the right led type and a reasonable current limit set (I would start with 1-3A, and see if that helps).

A brown out would match those symptoms.


I just set it for 5A. If it keeps happening then I will reduce it by .5A until it stops. Hopefully that solves it.