Update to SKR 1.4?

Hey good to know it is helping, what kind of changes were needed for you? Do I need to make them as well, or just for your setup…


I need to change the "Z AXIS timeout… I notice that the z stepper turn off with in 1 - 2 mins and causes that axis to drop and that could possible damage the piece that is either being cut out or engraved. I saw a post by Ryan that might fix it. He said it should for 6 mins before turning off and that was in the config.

Here’s the link to my config, config_adv.h and pins file:
Its Marlin2.0x ,BTT SKR1.4TURBO _TMC2209 AND TFT35 E3 V3.0 with dual endstops , its setting are for my setup.


Also Id like to figure how to have it reset xyz to zero(home for alignment purposes) and then have it move to certain point in the xyz to where I can start all pieces at but in the future. I really enjoy learning about this, its something I’ve never done other then config’ing for my FPV drones. and my RC Crawlers.

1 Like

line 649 in Configuration_adv.h

// Default stepper release if idle. Set to 0 to deactivate.
// Steppers will shut down DEFAULT_STEPPER_DEACTIVE_TIME seconds after the last move when DISABLE_INACTIVE_? is true.
// Time can be set by M18 and M84.
#define DISABLE_INACTIVE_Z true  // Set to false if the nozzle will fall down on your printed part when print has finished.

You can setup a G28 (home all axis’) followed by a G0X[whatever]Y[whatever]Z[whatever] followed by a G92X0Y0Z0 to zero your position in your postprocessor header section.

1 Like


I tried adding your 3 files to the stock SKR 1.4V Turbo Marlin code from BTT. I keep getting some errors thrown at me. Such as the missing SKR_common.h file missing from lpc1768. I am also confused why you have your board file named 1.4V and not the 1.4V_turbo as they differ between the lpc1768 and lpc1769. Thanks! :slight_smile:

Are you talking about the pins board file? [pins_BTT_SKR_V1_4.h], if not what file was that in? the congif.h , configadv.h or pins?

Rob I am currently trying to set up the same setup but for regular mpcnc not the lr2. if i used your guthub files what would i need to change? i am assuming dual x and y and single z but not sure what else would need to be changed.

Im not familiar with the MPCNC firmware. I based my setup off Teaching techs LR2 firmware with the skr 1.3 and Scottp’s skr 1.4 firmware. I changed several things to match the hardware that I was using. I had to put their files up next to mine and compared line by line to what i was using and make adjustments accordingly. I changed several lines in the CONFIG.H file, also made changes in the CONFIG_adv.H and the PINS.H using Scottp’s pins file for the end stops and drivers. I’ve study and researched several good videos on youtube and also on these forum’s( I lurk for weeks reading)
By no means am I an expert at this, it was a struggle to get it going and there are some things I still need to adjust. but I did get to home on all axis’s using the end stops and I did get it to draw the Crown and also got it to go thru the movements of a monogram door hanger that I stretched up on PS but i have not made the first cut yet.

All I can do is tell you is to look at what hardware you are using and compare it to my files , Scottp’s and others, then make the adjustments to your’s. or Even someone here that understands the language of the firmware can look at it and make more sense of the adjustments that i made to that firmware.

I hope this makes sense and just being honest.
Rob H

Ok heres a link to my build and to the changes i made in the config.h, configadv.h and the pins file.

BTT Skr v1.4 turbo, tmc2209’s, tft35 e3 v3 w dual endstops.

i hope that helps.

also in a different post in the skr boards with Jeffeb3’s help i added a Z touch plate on the BLTouch sensor pin out.

1 Like

Any one know why I’m getting not printer attached! Running a skr1.4 tmc2209 and tft24

I was getting the same message with my tft24.

I don’t remember the details but i did resolve the issue with a lot of help from edward. Have a look at this thread and you should be able to fix it. I know sometimes when i turn it on, it make take a moment for the message to go away but it does function as it should afterwards.


Hope this helps.

wrong serial speed selected perhaps, are both firmwares stipulating the same baud rate?

1 Like

Baud rate would be my guess too.

I was thrilled when I saw your post.
I bought same setup and waiting for V1 bundle to arrive.
I have no knowlage in (github, Marlin, coding and lines) at all, not a noob, more of landed from Mars :wink:

Is there a way I can use your preconfigured firmware to just flash it on to my board?
I would be so greatfull for that.

I really apriciate all the work you people put into this…

Changed the Baud rate and it didn’t change anything.

Even tried this from Edward using his test Marlin to try get a couple of steppers going but I still
got “no printer connected”. https://www.youtube.com/watch?v=v0PCzHGXTgk

I’m now assuming its a problem with the touch screen firmware. Mine has the Unified menu instead of the classic (like what Edward has in his video). Going to try update the firmware to classic and see if it makes a difference.

Yeah that didn’t work. No idea now

Can you connect with the computer? Maybe there’s something wrong with the board.

I just realized that i had help from two Edwards. Lol

Have you tried this also?

Edward NiedziejkoEdNiedziejko

Mar 13

This is probably serial port assignment. Set serial_port 0 and serial_port2 -1

Maybe it’s different for the other 1.4 vs the 1.3?

Great idea thanks board works fine. This video from Edward help a lot for checking https://www.youtube.com/watch?v=ujaqZknWqTo

1 Like

Thanks just tried it didn’t change. The TFT24 must be defective. Thanks everyone appreciate the help