Troubleshooting Octopus board

Every time I try to home the machine (typing in a G28), nothing happens and the connection between the Octopus board and my laptop via USB disconnects (using the desktop version of CNCjs 1.10.2). This was all working until recently.
I tried to reduce the current on my X drivers (typing in: M906 Xnnn X2nnn). Once I checked to make sure the numbers were entered correctly before moving any motors (typing in: M906), I saw that I should not have put in that 2nd ‘X2nnn’ variable. I then re-did it (typing in: M906 Xnnn) and both my X drives were changed to the correct current. This is about when I was having issues with trying to home the machine and it not moving.
M119 shows all endstops are ‘open’ (not triggered).
M122 shows that the motors were not engaged. I then do a M17 to engage them and still no luck with any homing movement. I can’t even do a G1 X1 (or Y or Z). I sometimes get the message:
"echo:Homing Failed
Error:Printer halted. kill() called!

Have I fried my BTT Octopus board?
Are there any other troubleshooting steps I can take to determine if the board is now no good?

I have that gut feeling. Didn’t see anything obvious in terms of burn marks on the top of the board.

Sorry if this isn’t the right place for this, I am using the Marlin_V1CNC_SkrPro_DualLR_2209_2.1.1_515 firmware. I thought there might be some folks on this forum who have more experience in how to troubleshoot a board to determine if it is still good or not.

Well, not knowing any other troubleshooting steps to take to figure out if my board is no good, I pulled a SKR 1.3 from one of my 3D printers. I compiled the SKR1p3 version of the DualLR firmware.
Things were working again (ie: I could do a G28X, G28Y and G28Z and not have the board give me that Printer halted. kill() error).


Or is this Jackpot?!!! :slight_smile:
Now I have a reason to get one of those boards and learn GRBL/FluidNC (and figure out a new workflow after using EstlCAM to generate my gcode).

This is why I got into this hobby. To learn and keep learning.


If you are using LR firmware you won’t generally have two X drivers.

I assume you switched X and Y nominally and left that out of the summary?

My build was the “Brutus”, inspired by the LR. Sorry, for a LR you are correct.