Trouble with Inkscape and EstlCAM

I’m trying to make a couple of signs for some guys at work. It gives me a chance to do some designing and practice on the machine with some different kinds of files. I’ve created a circular sign in Inkscape but when EstlCAM makes the G-Code just for the circle cutout it says there is over 100000 lines of code. I’m thinking it’s trying to cut up the circle into a lot of little linear commands. I have use G2/G3 arcs checked off in EstlCAM. When I try to load the code in UGS it says Error while starting file stream. I’ve successfully made some letter signs and cut out some squares but it seems the circles are an issue. Maybe I didn’t make them right in Inkscape? I found when I made an SVG in inkscape I had to select all the objects and use Object to Path and Stroke to Path both to make it show up in EstlCAM as I designed it.

Any thoughts?

Iv never bothered to check how many lines my gcode is does it not cut correctly? I’ll have to look into this also

Yeah, if you turn off G2/G3, it will make a bunch of little lines. You can try to turn them on and see how it goes (air cut, or foam if you don’t want to risk the material). Version 418, and 421 has some fixes for small arcs, but I think older versions work ok for big arcs.

Here is my SVG. (4.7 KB)

That works OK for me.

I zoomed in to the O with Inkscape, and switched to ‘Edit paths by node (F2)’ and could see that there were only 8 nodes in the inner circle and 16 in the outer (not hundreds), so that’s OK.

Then I opened it in Estlcam and just selected the inner circle, and it did it in about 14 arcs and a couple of very short straight lines:

;Project Robbins
;Created by Estlcam version 11 build 11.121
;Machining time about 00:01:14 hours

M03 S24000
G00 Z5.0000 F600

;No. 1: Engraving 1
G00 X113.1544 Y159.2039 F6000
G00 Z0.5000 F600
G01 Z-6.0000 F300
G02 X112.3591 Y165.7555 I33.3162 J7.3684 F300
G01 X112.3425 Y166.9460 F300
G01 X112.3587 Y168.1246 F300
G02 X113.6541 Y176.5689 I31.6279 J-0.5303 F300
G02 X119.4844 Y185.9563 I19.7661 J-5.7720 F300
G02 X129.3625 Y191.0230 I14.5322 J-16.1698 F300
G02 X138.9557 Y191.7537 I7.3720 J-33.4438 F300
G02 X147.7278 Y189.8537 I-1.2426 J-26.9370 F300
G02 X159.7735 Y176.5689 I-7.7221 J-19.1054 F300
G02 X161.0790 Y168.1246 I-30.0986 J-8.9761 F300
G02 X160.2834 Y159.2039 I-35.5931 J-1.3215 F300
G02 X156.8536 Y151.2774 I-21.6903 J4.6801 F300
G02 X145.8505 Y143.4048 I-17.1301 J12.3163 F300
G02 X136.7440 Y142.1144 I-8.7759 J29.1549 F300
G02 X127.6274 Y143.4048 I-0.4006 J30.0197 F300
G02 X117.1310 Y150.5375 I6.1231 J20.3002 F300
G02 X113.4030 Y158.2105 I17.2329 J13.1149 F300
G01 X113.1544 Y159.2039 F300
G00 Z5.0000 F600
G00 X0.0000 Y0.0000 F6000
G00 Z0.0000 F600


And if you turn off G02/G03?

Here is another one for example. If all I want to do is cut out the outside of this EstlCAM tells me it will be 100000+ lines and if I want to continue. Here is that SVG. (12.8 KB)

Thank you - I should have thought of that. With G02/03 off, it creates about 200 very short straight lines, not a million. I wonder what the difference is?

What dialect of gcode do you have set for EstlCAM to emit? With G02/G03 turned off, What setting is there for how to break the arc up into linear segments? e.g., max/min number of segments, min/max segment length?

I get the same behaviour with the Brentland image: about 12 arcs or about 300 short lines.

I’ve got Estelcam set to use Marlin, but I can’t see any settings for the number of segments.

I wondered if it mattered which units I used when importing. The first time I had used mm (and got 300 lines) so I tried inches and got about 200 lines, dunno if that’s relevant.

Not sure I understand. It creates an .nc file. I just tried another one with just 3 letters THE. It created a huge .nc file and the machine was oscillating around the same spot for a long time. It is really wierd. I ran an older .nc file I made last week and it came out perfect.English (2.5 MB)

Is the SVG in inches, and are you importing as mm?

Can you copy and paste the first 10-20 lines of your monster gcode file?

Here they are. Something isn’t working right with EstlCAM I think. I ran a previously created .nc file with no issue.

(No. 1: Hole 2)
G00 X51.0129 Y10.9303
G00 X51.4069 Y10.8608 Z0.5067
G01 X51.3888 Y10.7935 Z0.5232 F900 S24000
G01 X51.3594 Y10.7303 Z0.5464
G01 X51.3194 Y10.6732 Z0.5697
G01 X51.2701 Y10.6239 Z0.5862
G01 X51.2129 Y10.5839 Z0.5911
G01 X51.1498 Y10.5544 Z0.5826
G01 X51.0824 Y10.5364 Z0.5626
G01 X51.0129 Y10.5303 Z0.5358
G01 X50.9435 Y10.5364 Z0.5090
G01 X50.8761 Y10.5544 Z0.4889
G01 X50.8129 Y10.5839 Z0.4804
G01 X50.7558 Y10.6239 Z0.4854
G01 X50.7065 Y10.6732 Z0.5019
G01 X50.6665 Y10.7303 Z0.5251
G01 X50.6371 Y10.7935 Z0.5483
G01 X50.6190 Y10.8608 Z0.5649
G01 X50.6129 Y10.9303 Z0.5698
G01 X50.6190 Y10.9998 Z0.5613
G01 X50.6371 Y11.0671 Z0.5412
G01 X50.6665 Y11.1303 Z0.5144
G01 X50.7065 Y11.1874 Z0.4877
G01 X50.7558 Y11.2367 Z0.4676
G01 X50.8129 Y11.2767 Z0.4591
G01 X50.8761 Y11.3062 Z0.4640
G01 X50.9435 Y11.3242 Z0.4806
G01 X51.0129 Y11.3303 Z0.5038
G01 X51.0824 Y11.3242 Z0.5270
G01 X51.1498 Y11.3062 Z0.5435
G01 X51.2129 Y11.2767 Z0.5484
G01 X51.2701 Y11.2367 Z0.5400
G01 X51.3194 Y11.1874 Z0.5199
G01 X51.3594 Y11.1303 Z0.4931
G01 X51.3888 Y11.0671 Z0.4663
G01 X51.4069 Y10.9998 Z0.4463
G01 X51.4129 Y10.9303 Z0.4378

OK, a couple of things. That’s not Marlin-compatible. Grbl-compatible, maybe. Comments should be prefaced with a semi-colon, not in parentheses. Also, you’re running at 15mm/s, correct? That sounds fast, but you know your machine’s capabilities. Do you have the header for the file, or does is dig straight into the milling sequences?

I would double-check that it’s generating Marlin G-Code.

I’m using GRBL. Here is the start of the G-code file. This was also opened in notepad. I’m not sure the actualy G-code has parenthesis in it.

(Project English Blank Cutout)
(Created by Estlcam version 11 build 11.217)
(Machining time about 00:35:07 hours)

(Required tools:)
M03 S100
G04 P4
G00 Z5.0000

It looks like it is really slowly ramping down the Z. What is your plunge angle set to?

It stays in the same spot because that gcode isn’t even moving one millimeter in either X or Y and only about a tenth of a mm in Z.

I’m guessing you have a metric/imperial scaling issue.

Plunge angle is 90 degrees. It has to be a setting in EstlCAM that I must have changed by accident. I tried making a square in Inkscape and making the paths in EstlCAM and I got the same error again

Hmmm. Odd. Maybe share the estlcam project file?

Is it worth posting the Settings Estlcam.txt file, or any of the others, so we can compare to ours?

There are loads of settings, so it might be hard to spot the one that’s making a difference.

Alternately, is there a way to reset Estlcam to it’s defaults? Renaming all the settings files might work, or you might need to reinstall. Then check that works OK, then change one thing at a time to see what difference each change makes.