Tool probe works once

Hi All,

Just finishing off my LR2 to LR3 upgrade (pics to follow) but I just want to get everything working. My tools z probe works as expected the first time but when I try to use it after a tool change the head just raises by 20mm from where it is so if the head is at say 30mm then it won’t move down but just rais itself to 50mm as if it’s been triggered but the M119 says it’s open. Any ideas?


  • What specific firmware are you using? I assume LR Dual?
  • What command/g-code are you executing for the probe?
  • Where do you initiate the probe?
  • What kind of spindle/router are you using?
1 Like

Is it possible you had the router unplugged the first time and plugged in the second time? The bit may be getting grounded before it touches the probe.

1 Like

I ran into this when using G38.2 Z0, and have since changed to using G38.2 Z-10. The problem was, if the bit after the tool change sat higher in the collet, the machine won’t hit the touchplate before it reaches zero and stops looking.

1 Like

Sorry should have said that I’m using # V1CNC_Rambo_DualLR - - 513DL firmware. From memory if I run the custom gcode a number of times one after another then it works but if I try a tool change once I have run a job then it happens. Which come to think of it matches Matt’s problem.

Always get a probe with a wide flange on the end, that way you won’t lose it.

Wait, wrong forum… Dang it…

1 Like

You are the weird Uncle popping in every know and then, leaving a questionable comment and then go AWOL for a few days. I love it. :smiley:

Assuming you are executing the exact same command in exactly the same way, you are looking for something that is different between the two runs. Jeff and Matt list two differences. I assuming you are homing Z before your initial probing. One thing you might try is, during the bit change, home Z before probing to see if that fixes the problem. Also be aware of any coordinate changes (G92) you are executing and how they impact your probing target.

Gotta have life goals…

1 Like

Thanks Robert,

Before run I home Z and then use probe so good idea on homing Z again before tool change. I’ll try Matt’s code change and any problems then just home Z as you suggest.

Tried the Z-10, homing before z probe, disconnecting CNCjs, resetting Rambo 1.4 and still raises tool as if probe is triggered. When I use M119, Z min is open and when I connect probe plate to the clip you connect to the bit then M119 says that Z min is triggered. First time I use the probe before a job then it works fine

Your g-code looks fine. Just before you probe the 2nd time, get the position of the router using a M114, and verify the state with an M119.

Three ideas on the issue:

  • Intermittent wiring issue
  • Intermittent grounding issue
  • Electronic noise

To solve for an Intermittent grounding issue, make sure the signal pin from the control board goes to the plate, not the clip.

There are both firmware and hardware ways of addressing electronic noise, but I would not assume this is the root of your problem without more testing.

The behavior is too consistent, so none of the ideas are a perfect match to the behavior.

1 Like

I don’t know what program you are using, but is there a field specifically for tool changes that also needs to get updated with relevant gcode?

Aspire for toolpaths and CNCjs to cut. I’ll do some more testing tomorrow with spindle on/off etc and try Roberts thoughts.

When you run the macro and it doesn’t work (or acts like the probe triggers right away) your Z gets set to 25 right? And your X and Y are now 0? As in…the macro runs completely as if G38.2 has run?

I’m using a similar setup to yours (CNCjs, Rambo 1.4 and almost the same macro although I don’t reset X and Y during my probe as I often probe away from XY home). A big difference is I’m still on the LR2.

Haven’t noticed the repeatability problem BUT… there is something funky with the G38.2 command in that macro in cncjs. The macro will occasionally not perform any commands after G38.2 Z-10. So it will leave the probe touching the plate and not reset Z. Other macros don’t seem to have a problem completing all commands which is why I think G38.2 is suspect.
It’s really a macro itself, encoded in the firmware.

What code are you using to end a job before you run your second probe? Maybe I can replicate a test.

Hi Darwin,

Thanks for the offer of help.

I’ve just tested probe and it worked as expected so I turned on my VFD and it never worked so turned off VFD and it worked so swapped probe wires around, turned on VFD and it worked. My spindle is double earthed so could have been the issue.

1 Like

Hi Robert,

You pointed me in the right direction so thanks for your help. It was the VFD interfering so swapped probe wiring around.

1 Like

He has relatives here too