TFT firmware compiling issues

Hi all
do any of you guys compile your own firmware? im having issues and cannot compile the firmware from the v1 git hub (GitHub - V1EngineeringInc/BIGTREETECH-TouchScreenFirmware: support TFT35 V1.0/V1.1/V1.2/V2.0/V3.0, TFT28, TFT24 V1.1)

i have cleared the platforms out so it can install a fresh ststm32 but allways have a missing mcu or product line issue, i did search on the internet and found a post saying to add a product line into the bords json file (Compilation failure using platform-ststm32 10.0.0 - Development Platforms - PlatformIO Community), which i tried but that then made it throw up loads more errors. i would be greatfull if any one has any ideas regarding this?

Executing task: C:\Users\KarlW.platformio\penv\Scripts\platformio.exe run <

Processing BIGTREE_TFT35_E3_V3_0 (platform: ststm32; framework: stm32cube; board: STM32F103VC)
--------------------------------------------------------------------------------------------------------------------------------Platform Manager: Installing ststm32
Unpacking [####################################] 100%
Platform Manager: ststm32 @ 14.0.0 has been installed!
The platform ‘ststm32’ has been successfully installed!
The rest of the packages will be installed later depending on your build environment.
Verbose mode can be enabled via -v, --verbose option
PLATFORM: ST STM32 (14.0.0) > STM32F103VC (48k RAM. 256k Flash)
HARDWARE: STM32F103VCT6 72MHz, 48KB RAM, 256KB Flash
DEBUG: Current (blackmagic) External (blackmagic, cmsis-dap, jlink, stlink)

  • framework-stm32cubef1 1.8.3
  • tool-ldscripts-ststm32 0.1.0
  • toolchain-gccarmnoneeabi 1.70201.0 (7.2.1)
    AssertionError: Missing MCU or Product Line field:
    File “C:\Users\KarlW.platformio\penv\Lib\site-packages\platformio\builder\”, line 177:
    File “C:\Users\KarlW.platformio\packages\tool-scons\scons-local-4.1.0\SCons\Script\”, line 591:
    return _SConscript(self.fs, *files, **subst_kw)
    File “C:\Users\KarlW.platformio\packages\tool-scons\scons-local-4.1.0\SCons\Script\”, line 280:
    exec(compile(scriptdata, scriptname, ‘exec’), call_stack[-1].globals)
    File “C:\Users\KarlW.platformio\platforms\ststm32\builder\”, line 120:
    target_elf = env.BuildProgram()
    File “C:\Users\KarlW.platformio\packages\tool-scons\scons-local-4.1.0\SCons\”, line 658:
    return self.method(*nargs, **kwargs)
    File “C:\Users\KarlW.platformio\penv\Lib\site-packages\platformio\builder\tools\”, line 61:
    File “C:\Users\KarlW.platformio\packages\tool-scons\scons-local-4.1.0\SCons\”, line 658:
    return self.method(*nargs, **kwargs)
    File “C:\Users\KarlW.platformio\penv\Lib\site-packages\platformio\builder\tools\”, line 127:
    File “C:\Users\KarlW.platformio\packages\tool-scons\scons-local-4.1.0\SCons\”, line 658:
    return self.method(*nargs, **kwargs)
    File “C:\Users\KarlW.platformio\penv\Lib\site-packages\platformio\builder\tools\”, line 342:
    SConscript(env.GetFrameworkScript(f), exports=“env”)
    File “C:\Users\KarlW.platformio\packages\tool-scons\scons-local-4.1.0\SCons\Script\”, line 654:
    return method(*args, **kw)
    File “C:\Users\KarlW.platformio\packages\tool-scons\scons-local-4.1.0\SCons\Script\”, line 591:
    return _SConscript(self.fs, *files, **subst_kw)
    File “C:\Users\KarlW.platformio\packages\tool-scons\scons-local-4.1.0\SCons\Script\”, line 280:
    exec(compile(scriptdata, scriptname, ‘exec’), call_stack[-1].globals)
    File “C:\Users\KarlW.platformio\platforms\ststm32\builder\frameworks\”, line 43:
    assert PRODUCT_LINE, “Missing MCU or Product Line field”
    ================================================= [FAILED] Took 12.84 seconds =================================================

Environment Status Duration

BIGTREE_TFT35_E3_V3_0 FAILED 00:00:12.835
============================================ 1 failed, 0 succeeded in 00:00:12.835 ============================================
The terminal process “C:\Users\KarlW.platformio\penv\Scripts\platformio.exe ‘run’” terminated with exit code: 1.

Terminal will be reused by tasks, press any key to close it.

Is that the right MCU? According to BTT’s site the TFT35 v3.0 MCU is a STM32F205 and you are building it as a STM32F103VC.

Hi thank you for your idea,

I have downloaded a fresh zip to check and its preset to that MCU, and there is no 205 board file, I assume who ever compiled the build files that are included used the preset board files that are included in the zip, I have been through other default environments that use other board files and they all throw up the same error.

I have downloaded the latest zip from the BTT git hub (GitHub - bigtreetech/BIGTREETECH-TouchScreenFirmware: support TFT35 V1.0/V1.1/V1.2/V2.0/V3.0, TFT28, TFT24 V1.1, TFT43, TFT50, TFT70) to see if it was something to do with my VSC install or settings and this compiles straight out of the zip no issues but this build has the No Printer Attached issue when trying to use it with the skr 1.4 turbo firmware (Testing Firmware for LR2 on a SKR 1.4 Turbo with TMC2209 drivers - #31 by Karlwmiller)

I haven’t compiled it for a long time, unfortunately. I don’t think that repo has an automatic builder to test it either. I was using platformio on the command line, and I didn’t download anything manually.