Sudden speed changes on curved sections only

You are saying “seems” fine. How did you test each thing? Walk us through it so we can help or else we just guess and waste your time.

We hear this a lot “I did everything exactly how it’s written and it doesn’t work” Usually something is missed, and an obvious mistake is found.

It will take several weeks for a new CO2 laser to show up so let’s go through this step by step and figure out what is going on.You don’t need space right this second.

There are settings in lightburn, (and a nice little calibration pattern that can easily identify where the power stops increasing). What range did you set in lightburn and what range is in the firmware?

Is the test cut button pushed (limits power to like 1%)?

Did you unplug your addition and just use the actual pwm pin to the control board?

I put only the laser on the rig (not my mount - not that there is anything in my rig that would affect power… they are not linked).
The PWM is deducted from the incoming G-code.

The test calibration pattern seems fine. When I set this up, I cut a rectangle at 90% power, 200mm and measured the depth of that cut with a piece of paper.
With that I determined I needed to drop 0.8mm each pass, and that is what worked well all day yesterday.

Today, voltage is correct, PWM range seems correct ( lines created 10-100% seem incremental), yet a pass barely touches the surface of the black Acrylic I have been using as a test medium.

It works… I can cut through 2mm Acrylic at 50mm per second, but it therefore took 86 minutes to cut something out that took 12 minutes yesterday.
I just don’t understand what changed so radically while it was off overnight.

It’s not just the Acrylic settings that are wrong. My tested then stored library settings for cardboard and timber don’t now work either.

I don’t know how I can test the power output of the laser without some kind of specialist kit.

That is another whole day lost with no progress. I know I sound miffed (which is an understatement), so probably best I just step away. I can usually methodically work my way through problems and issue, but I nearly took a mallet to this thing earlier.

… and relax

I am referring to all your added electronics. Huge unknown for everyone here except you. If you bypass them, we will stop wondering if that is the issue.

Okay, so how does it work today? At what power does the power stop increasing?

POwer supply voltage?

Did you test that with a O-Scope? Why does it seem correct? Lines? The test pattern I am referring to makes little filled in squares.

It really can be a lot of things. We need to work through it systematically. It is not everything broke and it is worthless, SOMETHING is different we just don’t know what.

The calibration squares are a great place to start. Lets see what the pattern looks like I really feel that will reveal a lot of info.

Take a break. I am the kind of person that enjoys figuring this stuff out. BUT…nto when I am trying to get something done. So I know the feeling.

There is a chance the laser burnt out, but that is the last resort. I have no idea what laser you have but some have 4 lasers inside and some or all of them could not be working. That is worst case.

1 Like

Pictures would help.

Not looking at it today if I can help it.

All my electronics are disconnected. It has a clean 12v and the PWM signal and that is it.

If you send M42 P45 S###, the laser works in incremental power outputs (visually) as you would expect.

Don’t have an O scope, so can’t try that.

Calibration pattern looks OK. But… maybe down on power. Difficult to tell.

If I run the laser at 100mm per sec, at 90% power, 12 passes over the same line… it’s barely 0.5mm deep in the black Acrylic. And that isn’t melted plastic… it’s just not cut.

I could cut the same piece of 5mm Acrylic at 200mm per sec, 90% with 8 passes the other day.

I suspect the diode has already started to die.

I’m still very new to lasers so take this with a grain of salt. But is it possible your lens is dirty causing it to be down on power?

This is the first I have heard of a laser loosing power like this unless it is a multiple laser version.

I know you said you cleaned the lens but did you take a close look at it. If you got enough residue on the lens while it is powered on it can melt its on lens and destroy the optics.

If you power it on is the “spot” projected on a far wall really nasty looking (or does is till have nice clear crips lines), or can you see the distorted spot on the lens itself? A new lens is very cheap.

Looking at your setup I see 3 hoses running down to it. I assume you had a ton of airflow at all times, but if you ever did test fires without them on this could be the issue.

On mine anytime I am near the laser that is going to be used, I have a compressed air stream running and my goggles on. a little residue will kill it permanently.

I don’t have a ton of experience with lasers. But I do remember a lot of tear down reviews of the earlier lasers being concerned about this. They would comment on the amount of cooling the diode was getting and whether the rated power was within spec for the diode. I have no idea how you would tell if the manufacturer was telling the truth about any of that from looking at the website description. That is the risk with buying these direct parts.

Is there a warranty? If the manuf. doesn’t feel the pain in their pocket, they wont ever change. That is a big difference between theis and a dewalt or makita.

I don’t know how you would tell if the diode (or just one of the many diodes) died. The best test I can think of is exactly what you’re doing. Measuring the performance by cutting times.

I knew I would end up back on this…

Lens has been cleaned with Isopropyl many times… clean. Air assist is pretty efficient and should keep the crap off the lens. It’s probably only run <4 hrs.

Took it all apart. Checked the lens, and everything I could think of.
Either… the focus is somehow way off (I have tried passes stepping 0.5mm +20 and -20mm either side of my original focus point). Which I suppose ‘could’ be a damaged lens… but no idea how that happened.

Or, as I suspect… this is a crap diode.

Which ever it is, you do need to draw a line at some point, and I am certainly not buying a new laser.
I have contacted the seller… but I don’t hold out much hope on that front.

I have have thrown another afternoon into this and got nowhere. I must stop.

The second hand Co2 comes on Wed, and so I can put this to bed.
Thanks all


Lens has a tiny crack in the centre :face_with_symbols_over_mouth:

That will be it then… 3 hrs use… outstanding


I am glad you found the culprit after all! Seller should exchange it, shouldn’t he?


My question is why that has failed with barely any use?
I have pretty powerful air assist blowing away from the lens, and also air assist blowing across the work.
The laser is up inside the housing and the laser leaves via a tiny hole (that the air assist also blows out of).
Chances of anything getting up onto the lens is pretty small.

My only other thought is the cooling fan blows down past all of the laser housing, and therefore could suck in stuff from above I suppose in theory. But would it stick to the lens?

Anyway. I know why now and not much I can do about it. I have asked for a replacement, but I am taking the MPCNC down today for the new CO2 laser cutter. Will have to be something I return to another day.

1 Like

I’m sad to see you will no longer be using the MPCNC and diode laser. I purchased one a couple of months ago for my MPCNC and have really enjoyed learning to use it. I was hoping to follow along with you and learn more! You are obviously very knowledgeable and I was hoping to glean some of that knowledge from you.
I hope you enjoy your new CO2 laser.

1 Like

It could have been shipped dirty. Something was on the inside when assembled. The two sides of the lens are equally susceptible to contamination damage.

You should be able to grab a lens pretty cheap if they do not get back to you. You can change focal length and shape to a small degree that way.

1 Like

I have heard of them cracking from heating up the oils transferred from touching it with bare hands. Not saying you touched it with bare hands but a tiny amount of grease or oil from assembly could have been the culprit. It could also have been an imperfection in the lens that once again it heated up and cracked.

I purchased a spare lens for my laser for ~$20. But it sounds like they should send you one for free.

Best of luck!