Still need laser help

Can someone please tell me where to edit the code for pin 45 on a rambo board? I’m trying to get this setup today and do some testing…

I’m using a 5w laser that is controlled via a 5v pwm signal.

I have everything wired i cant find the “servo” pin edit in the firmware nor the “fan1” pin edit -


Thanks in advance for your help


Marlin/SRC/Pins From there it depends on the Marlin version you are using, but look for RAMBO.

1 Like

I’m not entirely sure what that means, Ryan, but here is some more context of what I’m working with:


I now know you were talking about the folder for the pins header file… pin 45 seems to be defined…

I found the pins_RAMBO.h and 45 seems to be set, but not being controlled when i export the gcode in lightburn


// M3/M4/M5 - Spindle/Laser Control
#define SPINDLE_LASER_ENA_PIN 31 // Pin should have a pullup!
#define SPINDLE_DIR_PIN 32

This is what I did to set it up ( see images).

I supplied the laser with 12v and GND and ran GND and the 5v PWM pin to GND and pin 45 on the Rambo 1.4 board.

Also the laser has an on and off button and when you turn it on it goes full power. Is there a way to make it not do that?

I am not comfortable giving advice on a laser I do not own.

Please see the laser page, we do not currently use M3-it is not working in marlin yet.

1 Like

1 Like

What is a good alternative that is working with marlin - what pin should i use?

I understand you dont feel comfortable, but I want this to be operational, and i feel im spinning my wheels.

I want to try something,…

i guess should I try 23 or 31?

My first cut seemed to go well, but things are getting wonky…independent of speed

I have the pins used for every board I have tried listed on the boards page. I thought they were linked form the laser page as well? For 12V you use a fan port, for 5V you use a signal pin specifically the one I have listed for your board, each is different. There are also other pins you can use but most only need one free pin.

Looks like your laser is not turning off. Maybe post your gcode or describe how you made it.

1 Like

Im using pin 45:

When I enable: #define SPINDLE_LASER_ENABLE

I get the following (verbose) error compiling:

Arduino: 1.8.9 (Windows Store (Windows 10), Board: “RAMBo”

error.txt (200 KB)

wierd i cant get the firmware to compile - im trying to use the Duel Endstop/ LCD/RAMBO version - compiles without defining the laser bool

Uninstall the Windows Store version of Arduino and install the normal Desktop version. The WS version isn’t terribly robust. (And for heaven’s sake, attach a text file to your message instead of dumping forty-eleven pages into the message body. :))

1 Like

im using lightburn to create the gcode. i tried to execute from lightburn and Repiter.

attached the gcode:


20mm-circle.gcode (2.21 KB)

I installed arduino using the installer and not the store and im still getting the following errors

error2.txt (3.73 KB)

That’s the older (1.8) version of Arduino. Any of the 2.0 Marlin builds need 1.9 or the current beta version of Arduino.

1 Like

I get the same error with the beta version as well

Multiple libraries were found for “SPI.h”
Used: C:\Program
Multiple libraries were found for “U8glib.h”
Used: C:\Users\User\Documents\Arduino\libraries\U8glib
Not used: C:\Users\User\AppData\Local\Arduino15\packages\rambo\hardware\avr\1.0.1\libraries\U8glib
exit status 1
Error compiling for board RAMBo.



You need to wipe out all of the arduino stuff and start over. Follow the flashing instructions on this site. The U8glib libraries is messing it up.

1 Like