Steppers not holding torque between moves

I’m having an issue with stepper drivers not holding torque between moves.

The steppers move just fine on command, but holding does not seem to be enabled as I can easily push the gantry around after a machine move.

I’m using TMC2225 drivers on a Tinybee board running FluidNC. I’m not sure if this is related to the TMC2225 driver or my FluidNC configuration.

Any ideas where I should start looking to troubleshoot this?

Thanks in advance.

Some drivers have a setting that disables them or at least lowers the current after a certain amount of time so they stay cooler. I don’t know whether it’s your drivers or the bee, but that would be my guess. :slight_smile:

I figured it out. The idle_ms is was set to 0. It should have been set to 255.

It’s holding now.

  • idle_ms:
    • Type: Integer
    • Range: 0-255
    • Default: 250
    • Details: A value of 255 will keep the motors enabled at all times (preferred for most projects). Any value between 0-254 will cause the disable pin to activate this many milliseconds after the last step. Note: Motors can be manually disabled at any time with the $MD command.

See, that’s what I meant and you found it! Neato! :slight_smile: