Stepper not working right

Hello, For a super quick overview I finally got my Lowrider assembled and I am having trouble with stepper motor.

I am using the Rambo board/LCD and 35V power supply from the v1 shop. RAMBo v1.4 Pre-Flashed for CNC – V1 Engineering Inc

The steppers I had laying in a box I found so they are all brand new, but possibly a few year old (don’t know if that matters). From the label and printing on the motors, they are these:

I have only been using the LCD so far and have not connected it to a computer yet. I was just trying to get the wiring order of the stepper wires so they move the right direction. My connectors I thought would fit didn’t so I got some coming in. In the meantime I took jumper wires and soldering those to some of the wire I got with only male pins on to stick in the connector on the motor and rearrange easily if needed. Pictures are of that whole connection from Rambo to joint (half of those are clear heat shrink) to motor. Pins going to motor connector also clear heatshrink.

So I connected wires to X motor port on the Rambo and when I try to move it, it doesn’t move. The video has me trying to move it 10mm a few times.
Video link: Dropbox - IMG_6242.MOV - Simplify your life

I also get continuity when I check A+ to A- (black/green) and B+ to B- (red/blue) so I believe that means the link for the steppers I correct.

I’m not sure how to go about troubleshooting this, if there’s anything else I can provide let me know and I will get it.

Thank you

12V power supply? Rambo is only good to 24V.

You can short on coil (when it isn’t connected to the Rambo) and try to turn the motor shaft. Shorting the coil will make it much harder to turn (magic :magic_wand:).

Steppers almost never die. Intermittent wiring is one good possibility. If, for some reason, the firmware wasn’t set right in the Rambo, that could also cause similar jumpiness.

Maybe wrong power supply. I think I’ve got another around I can try. I thought I saw on a diagram it was 12-35.

By shorting coil you mean just take A+ to A- while power is off and try turning it?

I have one of these around, will this work?

I shorted the pins and that felt the resistance turning the motor change, that is magical.

I also hooked up the 24v power supply and tried again and it does exactly the same thing.

1 Like

So last I remembered I have an orbital extruder I got for my delta I haven’t installed yet - which has a tiny itty bitty stepper.

So I used my makeshift harness and stuck the pins into its connector and tried it - it spun exactly as I expected it to (better since I had no idea what colors went to each coil).

So I would assume this means by Rambo was correctly configured correct? And since the same makeshift harness worked with this stepper, then the stepper on my Lowrider must be the issue?

I’m not sure how to proceed debugging from here.

EDIT: I just powered the machine down and disconnected the tiny stepper. I don’t know if this matters but it was hot when I went to put it back in it box, maybe just because it’s so tiny?

Yeah. That motor probably needs less current.

In my experience, stepper motors are really hard to break, but the wiring isn’t. Maybe the wiring or connections on the motor are the problem.

The current definitely could be, he is so very tiny, I have no seen such a tiny stepper, which makes it good for the delta printer.

The thing is I used the same harness and even method of sticking the male pins into the connector, although the fit was tighter around the pins. But the male/female connection to asshole motor are the same type.

How would I go about actually testing said stepper? I think I have connectors that my ender 3 motors use, then connect to ender and basically do same thing - go on lcd and try to move whichever one I plug it into? Or is there a better way?

And thank you for replies, it has been a major buzzkill. But I can rule out that it is something in the firmware because tiny motor worked correct?

Don’t you have 5 motors for the machine?

Yes I have 5, and I tested it on another stepper and that worked just as expected up and down. I should have tried that originally.

now that my connectors came in going to make a the x (one that sits by router) and use that one to go around and check if any other steppers are crap.

So if anyone else encounters this problem try another stepper and it will make your life much easier to test steppers before attaching them in case one is bad.

Thank you for your help and patience, very much appreciated :slight_smile: