Step per revolution / Distance per revolution

Hi, trying to set correct the travel distances, if I

  • AX10 runs 10mm
  • AX50 runs 50.05 mm
  • AX100 runs 101 mm
  • AX400 runs 404 mm
  • AX500 runs 505 mm
  • AX600 runs 606 mm
    No matter how I change the settings, the difference always increase with the distance.

You are off by a consistent 1%. I assume you are referring to a MPCNC and are running Marlin. You can “fix” the problem by changing the steps per mm either from the display or by running a bit of g-code, but I suggest trying to figure out where this inaccuracy is coming from before making any changes. All the components on the MPCNC have fixed ratios, so a 1% inaccuracy should not be happening.

Agree, already check all the axis for tightness, all stepper drivers and motors are the same for all axis.

You can fix your problem by reducing the number of steps per mm in the firmware by 1%. Is the problem the same for the Y axis?

How do you change things in the firmware

What are you trying to change and why?

Everything we create and run through Estlecam ends up being way way tiny on the mpcnc. I read in these posts it may be in the firmware.


You need to make sure the units are the same when you bring the file into EstlCAM. If you have mm in your CAD programs and Inches in EstlCAM, you will have 1/25.4 parts!! :grinning:

Double check that you’re using the same units when you export out of CAD and import into CAM.


As Mike indicated, usually this problem is due to how you have Estlcam set up. The Marlin firmware, as configured by V1, does not accept inches as input. You can author your CAD in inches, but you must specify millimeters as the length measurement to be fed to Marlin. I believe the setting you are looking for is under Setup/CNC Programs/Marlin. It should look like:


You may want to take a look at your other Estlcam settings. The V1 recommended Estlcam settings can be found here.

It is possible to enable the Marlin firmware to accept inches as input. It requires making a change in configuration.h, recompiling, and reflashing the board. I don’t know of anyone this forum that runs with this feature enabled, so there may be issues. Uncomment this line in configuration.h:


Hi yall, I am having the same issue as John, my SVG and DXF files come into estlcam fine and scaled correctly, but when I save it to gcode and then give it to MPCNC it is scaled completely wrong and tiny, like the 12in ruler pictured comes out to be 79mm or 3.12 when cut into material (using 1/8 end mill, engraving on centerline). I just went through the recommended settings that Robert posted and linked to and am still getting the same issues. If it helps at all when I run the crown gcode it comes out fine and not tiny, so I think I am just having a disconnect between estlcam and the gcode it is spitting out.

Should I go into the config.h file and increase the steps per rev to compensate or if yall have any tips I would really appreciate it. I tried to get all the Estlcam settings I am using into the picture but let me know if yall need anything else.

I’m not an Estlcam user, but I cannot think of a way that a setting in Estlcam can result in cuts 4X too small. Usually, 4X mismatches are due to microstepping settings being wrong, but it would be more likely to be 4X too big than 4X too small. There are a few steps to troubleshoot this issue:

  • Author a rectangle of a specified size and use it in Estlcam to generate a file. Run the file and see if it is off by 4X.

  • If it is off by 4X, post the g-code to the forum using the upload icon.image You can also take a look at the g-code yourself. You are looking to see if the difference between the minimum X and maximum X values is accurate to what you authored, or if it is 4X off.

  • Move your machine a set distance and measure the result. This can be done with a simple g-code command:

G1 X400 F400

This g-code tell the router to move 400mm in the positive X direction. Do you get 100mm or 400mm of movement?

Tell us about the control board you are using including stepper drivers and where you got the firmware.

The above tests/information will indicate whether your issue is firmware/hardware or an Estlcam issue.

1 Like