Starting gcode

I have the Primo MPCNC with a mini-Rambo board and the newest Marlin firmware.

I want to use the Start Gcode text in ESTLCam. I tried copying and pasting the example from the docs. I only want to Home Z.
When I run my gcode, it probes and homes Z. Then it moves to the beginning of the first Engrave and lowers to the correct spot and depth of cut. Then it stops there and doesn’t move. I don’t understand why it is stopping. Thanks for any help.

Here is my gcode:

;Project LHGnochi

;Created by Estlcam version 11 build 11.245

;Machining time about 00:44:34 hours

M05 ; PID, Stop spindle

G0 Z6 F500 ; Raise Z axis 6mm

M00 ; Wait for LCD button press

;Change tool: Ball Nose 1.5

G28 Z ; Home in order, w/zprobe

G92 Z1 ; Account for probe thickness (set your thickness)

G00 Z5.0000 F500 ; Raise Z probe off off of surface

M00 ; pause for LCD button press


M03 S18000

G00 X0.0000 Y0.0000 Z0.0000 F2100

G00 Z5.0000 F480

;No. 1: Engraving 2

  • G00 X11.2361 Y76.4176 F2100

  • G00 Z0.5000 F480

  • G01 Z0.0000 F2.000 S18000

  • G01 Z-1.0000 F2.000 (It stops here)

G01 Y197.2500 F4.167

G01 Z-2.0000 F2.000

G01 Y76.4176 F4.167

G00 Z5.0000 F480

It hasn’t stopped. It is just moving very slowly. Feedrates in Marlin are millimeters per minute, so you are moving at 2.0 mm per minute. If you take a look at this line:

 * G00 X11.2361 Y76.4176 F2100

Your F parameter is setting the movement 2,100 mm/minute. But then look at this line:

* G01 Z0.0000 F2.000 S18000

The F parameter is 2.0 meaning you are moving at 2mm per minute.

I’m not an Estlcam user, but I suspect you have the following setting (in Basic Settings) wrong and are sending millimeters per second instead of millimeters per minute to Marlin:


Thank you very much Robert! I changed the Feed Unit to mm per minute and it works now. Everything else in the Docs shows mm per second. I assumed all of them were mm per second. It’s strange that it worked fine if I didn’t add the Gcode Start code to it. Oh well.
Thanks again
Screen Shot 2023-05-12 at 6.11.35 PM

1 Like