Some issues with steps per mm and height when cutting with newbuild

I’ve finally got my lowrider up and running after life got in the way for about 3 months. I have a couple of problems which I’m hoping to get answers from this forum.

I’m using skrpro v1.2 with tft35 bought as part of my lowrider kit from V1 engineering
and have wired my steppers in series.

The good news when I test with pen is my crown looks like a crown and a square looks like a square!

1st problem, I noticed the dimensions were out by a lot when testing on a simple square, checked the steps per mm and these are set at X80 Y80 Z80. When I change these to X50 Y50 Z200 all my movements are now correct. I changed this with M92 command in repetierhost but this resets to previous settings each time I restart. How can I make this a permanent change?

2nd problem, when I run a program created in estlcam for a 6mm cut, made as a series of 1mm cuts it won’t go further than 2mm deep. There is nothing physically restricting the router from going down this far and I’ve checked that the gcode has a series of cuts at -1mm, -2mm, -3mm, -4mm, -5mm and -6mm but when watching it run I can see that the z leadscrews aren’t turning at all each time the program should be dropping down a mm.

I’ve run several cnc machines previously using various cam programs but quite new to building my own so any help appreciated!

1 Like

I am close to where you are in general configuration. I found I had to review/reset the Estlcam Basics once or twice to make sure I have not lost any millimeters or other settings. Also I have found that writing something and looking at the gcode and maybe changing the gcode by hand helped me. I am not sure I am helping. I did find that I couldn’t go negative on any axis until I reflashed the firmware after I had accidently tried the Estlcam Controller program with the computer plugged into the SKR Pro.

Get the firmware at MarlinBuilder releases.

You don’t have a flashed board and screen. The steps per mm should be 100,100,400, but there are other issues you’ll have to fix with new firmware too.

It seems since you are getting the correct movement with 50,50,200, that you stepper drivers are set for 1/8 microstepping instead of 1/16 like they should be to conform to the standard steps/mm that Jeff referenced.

Also, to make your changes permanent issue the M500 command.

Thanks, I will do that. I was sure I had already done that when I first connected and tested my steppers, but I think something hasn’t worked there as it fits my issue.

Thanks Adam, I agree, getting to understand the gcode if something simple and how to modify it is really helpful.

1 Like

Thanks, I’ve flashed the board and screen and now I get the V1 logo at startup and 100,100,400 for the steps so I must have missed doing this earlier. Rookie mistake!!!
I haven’t tried running a test program yet as I’ve taken the xz apart to straighten up my rails which are sitting slightly out of square.

You mention that there are other issues that I’ll have to fix with the new firmware, what are these?

That wording was weird, sorry. There are other issues, and the new firmware will fix them. You should be in a good starting place for the firmware.

Cool, I hoped that was what you meant!

Big progress today, after the firmware update I’ve now cut the crown plus a couple of other test cuts at different depths created in estlcam.

I have a bit of binding in one z leadscrews, it doesn’t drop all the way down when powering off and when I turn by hand I can feel ‘tight’ spots so a bit of work required here to get it running smoothly.