Some creations and a bit of learning

I soldered a connection from the case of the spindle to an earth lead, and stuck my multimeter between it and earth, just out of curiosity really. I have no experience to put the measurement in context though, so it could well be nothing, as you suggest. The LCD is now about 4 feet away from the spindle power supply, but I’m still having problems with errant movements. I know they are caused by having the spindle running, but it has worked with the CNC perfectly in the past, so I’m puzzled. One way or another I’ll work it out, but it’ll come to me in the middle of the night in 2-3 weeks :smiley:
Thanks for your input Jeffe, it’s much appreciated.

1 Like

I seem to have solved my problem, I have run three jobs which have completed perfectly. However, there was no single thing I can ascribe this to, and I have a strong suspicion it’s a confluence of two issues.

  • I physically separated all cables so none were close and none were co-linear
  • I removed all my earthing cables (these made things worse, possibly through the mechanism @ttraband warned about)
  • I reformatted (the slow way, the fast way made no difference) my SD card

This made things run much better with just the odd blip. Then yesterday I moved an old laptop into the shed and installed Repetier Host, attached to my board and removed the LCD Display from things completely. Three jobs ran perfectly. Yes!
I’m slightly uncomfortable with a dual cause for all this (spindle power interfering with data from card to board, despite their physical separation), but it seems the only reasonable explanation.
At first I thought this comment from @jeffeb3 was rather unhelpful “The machine is dumb”, but actually it is a fact that I needed to use in all my problem solving. I will not forget this.
Thank you all for your patience, I’ve learnt a lot. I have also learnt that this machine means rather a lot to me which is either weird, or a huge accolade, depending on how you look at it.
Lastly, I finished off a little practise sample: ignore the imperfections in the shapes, that was my poor execution of the cuts, but I was wondering about creating floating shapes in resin by cutting not quite through the material, filling with resin and then planing of the back. Works well, and I think this could be interesting. No ideas what I could use it for yet though.

3 Likes

Haha. I like that sentiment too. Barry has a sign in his barn that says, “This machine has no brain, use yours”. I also like this silly fake sms message I made for the docs:

https://docs.v1engineering.com/learn/gcode/

Glad it is working for you.

That resin idea is great. There was another user making knife handles with a similar technique (sorry, I forgot the name). I imagine you could make nice pen blanks too. Or, at the scale you have, maybe a lighter color resin could be used for a lamp or wall sconce.

Thanks Jeff, I will be making an appropriate sign soon to that effect!

The resin thing: I just realised it’s not obvious what is wood and what is resin. The parts cut from wood are dark brown, the resin is the light bit inbetween. Now all I can see is floating, hollow white diamond shapes in a sea of brown resin :smiley:

Oh, now I see it. That actually makes more sense.

I don’t think I’d ever seen that .DOC before.

Typing .DOC in the forum search box brought me to:
https://forum.v1e.com/t/learning-doc-pages/15271
the first post of which lists 4 learning .docs.

I know there are other .docs such as ‘milling basics’ but I can’t seem to find a table of contents listing all available .docs. Am I chasing a wild goose or is there one somewhere? I’d just hate to pass over available, helpful information.

On a desktop, the whole list is on the left. On mobile, there is a “hamburger menu” button in the upper left side.

Now, this useful tidbit of information will be entombed here, at the end of this thread:

It’s clipping it funny, but you can click it to see the whole thing.

Well, I don’t know if I need more coffee, I have a severe case of Monday morning stupid, or my laptop came from the bargain bin but: on the left of what?

I see that list if I scroll down to the link for “New Community Docs” on the home page and click it but the first time I click on one of the links I get the little image of a magnifying glass and it just cycles a little bigger/smaller while not leading anywhere.

It may be a little different on a smaller screen. Also, in some cases, you are only presented with a subset of the menu, and you have to hit the left arrow to go up in the hierarchy. Here’s what I see:

On mobile (and maybe smaller screens) the left panel sometimes instead shows the main topics on that page. In the screenshot I just posted, you can see things like “About V1”. That can replace the left panel if you don’t have enough room for both. In that case, there is an arrow to back up to the list I’m showing you.

If you’re still having trouble, maybe make a new post with some screen shots, and I can take a look.

Unless you have a link to a different page, this is what I get, nothing at all on the left. This is the only page I remember having this type issue with. At least maybe the white coats won’t be coming for me soon. :crazy_face:

On this page:

Clinking one of the links on the left changes the cursor to the little magnifying glass symbol and clicking again just toggles a size change.

This is presenting the smaller version, with the menu compressed. You can click the menu icon in the upper left of the screen. It looks like this:

hamburger

Obligatory wikipedia page: https://en.wikipedia.org/wiki/Hamburger_button

Well, now I’m getting thoroughly confused. I see that symbol in the first screen shot I posted above. In trying to return to it and try that symbol, and I’m 99 44/100% sure I took the same steps, I arrive at the page seen in the second screen shot I posted above. Thinking it was possibly one of MicroSoft’s charming little quirks I tried it with GoogleChrome with the same result. Now I can’t seem to find the way back to the screen in that first screen shot and it’s not like I took a number of steps to get there first time around.

EDIT: OK, I see the URLs for the two screen shots above are different but I’d swear I reached them thru the same link. I got back to the first page with the three line icon and it gives me a menu for the MPCNC instruction pages. I was looking for a list of all available DOCS, surely there are some not associated with the MPCNC?

The display is based on the size of your browser window. If it’s big enough you get the second of your images, if it’s too small you get the first. When you are in the first and click on the ‘hamburger’ you should see this menu:


Note that it has the same menu entries that the second picture shows. If you click on ‘Build’ it gives you a deeper menu where it asks which project you want to build, MPCNC, Low Rider, MP3DP, etc.

1 Like

Yeah, I don’t know, maybe I was chasing my tail for a bit. The link to ‘New Community Docs’ on the home page doesn’t get me to the docs. I don’t know if it’s new or I missed it but the DOCS link on the forum page gets me where I want to go. Thanks

More signs, the smallest text is beautifully crisp in MDF, but not so good in wood. I think maybe this is because a rate which cuts well with the grain is not the same rate that cuts well across the grain. That said, Elm works really nicely. Sapele is rubbish for fine carving (in my hands).

I don’t know if this is ever a problem for anyone, but I needed to do some tightening of the gantry (I’ve not even tightened it since construction), but this very simple discovery made it a lot easier: a socket fits in there. Throw in some kind of restrictor (I flattened a bit of copper pipe), and things are much easier.

1 Like

I decided to test out my theory that with the grain and across the grain were producing different results. I was pretty sure I’d see ovals as I cranked up the speed and DOC. Wrong. I was also bothered that there was too much play in my spindle mount/gantry/system. Wrong again.

This means I need to look at estlcam and my work to try and find the reason behind the occasional weird shapes of small text.
This did get me thinking about stress tests. I know this is a tricky subject, because the idea that we could put together a test that everyone can implement and compare the results and find meaningful data in them is, er, remote and a serious challenge. The Crown test is great for testing the machine is working and is square, but it would be nice if I could run a test which would confirm whether I’d achieved the expected rigidity. A deflection stress test? That said, however useful it might be, I can imagine the more vociferous builders with incomplete constructions might drown out any useful purpose. OK, I’ve argued myself out of it. I may run my stress test at 3 and 4 mm DOC.

The other reason that is tough is any slight deviation in build size will change the expected numbers. Best case would be a range of verified numbers and you could compare to see if you fall within that range.

So we fall back on milling speeds and build size.

Good points, everyone’s build is different. I guess it’s obvious I’m thinking about these things for the first time, but you’ve put much more thought into it. I’ll get there. Eventually. I’m still like a kid in a sweet shop.

No, not like that at all. This actually never came up much before. Recently though more thought has been put into it. I really do appreciate the brainstorming.

1 Like

Last night I set up my relay to control my spindle through the fan output of my minirambo. Then I realised that carving in estlcam suggests an endmill to cut wider flat areas in addition to the required V bit tool. I took the code and divided the two scripts, ran them separately and added M106 P1 S0 to the end of the second. Then watched as it turned off after completion. I felt like a god.
That mere mortals can achieve this stuff is amazing.

One question though: how do I get the code to pause briefly to allow the spindle to get up to speed. I suppose I can just have it move to the starting position slowly, but is there a pause…?