[Solved] V1Pi Problems: SSH/Connection Problems, CNCjs Forbidden Access

I’ve tried installing both 17.0 and 17.1 images of V1Pi (no hotspot version) and am running into the same problems.

SSH from my MacBook Air: (input $ ssh v1pi.local)

  • Doesn’t respond, or
  • once I am able to log in, I cannot type anything (cursor blinks but no characters show up). Sometimes it may initially work but then won’t respond to typing.

After the pi loads up, I can get to v1pi.local through the web browser, but neither OctoPrint nor CNCjs will load up.

  • Octoprint will continue to load but never change screens from landing page.

  • CNCjs instantly goes to Forbidden Access.

    • I saw in another thread that changing the index.html for the landing page may help (change CNCjs port from 5080 to 8000); where is that file located?

  • Both processes can be stopped/started and restarted without problems using the buttons on the landing page.

Any ideas?

Thank you.

Edit: Blurred a point above because I found and edited it, no change (page keeps loading but doesn’t go anywhere).

Edit 2: Updated Raspbian through console. CNCjs seems to work now with the port:8000 change, but nothing else is different.

Updating Raspbian through console
sudo apt update
sudo apt full-upgrade

Got it working after checking that it wasn’t the Pi. Turns out that the new gateway we got from AT&T doesn’t like the the RPi for some reason… thanks to a random result from Google I took a shot and went into the (kind of limited) router settings and added both of the Pis to the MAC Filter List (but didn’t actually enable whitelist/blacklist/other the setting for any of the Wifi bands (2.4/5Ghz).

This allowed me to SSH into either of them with no problems (and made the web UI actually load/be more responsive).

An additional note: I did have to change landingPage.html and point CNCjs to port 8000. 5080 was giving Forbidden Access when I clicked on the CNCjs logo, but navigating directly to v1pi.local:8000 worked, so instead of having to do that manually each time I just changed that setting. @jeffeb3 Sorry to tag, but is this something unique to certain setups or should it be pushed to the next update? Also, does CNCjs only accept .nc? When I try to upload gcode it just loads, whereas nc is instant (basic search says the extensions are about the same, and I didn’t notice any odd behavior running the crown gcode as an nc).

Overall, pretty happy so far. The upgrade to Primo is now nearly finished as the machine as drawn its first crown. All that’s left is figuring out how to run the wires. I don’t see a way to run them all cleanly, but after redoing some of the braiding and using wire harness tape, they should stay secure and not using zip ties around the end of the braiding will allow them to slide through the tubes easier.


I have the same issue with the Forbidden access. I guess I could make a github branch and edit it for my own need, but I find github too intimidating to even consider it. It would be nice to edit these settings locally, on the sd, but I haven’t found it…

I hate networking. It always seems like it follows these logical, simple rules. But then occasionally it just doesn’t work right. I sometimes work on unmanned ground vehicles that have several computers on them. Honestly, it feels like 1/3 of the time in the vehicles we are dealing with networking or power issues.