SOLVED: BTT touchscreen freezing before I can start a cut (using firmware recommended by V1)

Board and touchscreen I have:

Board: BigTreeTech SKR Pro 1.2
Touchscreen: BigTreeTech TFT3.5 E3

My BTT touchscreen was working fine. But now it is freezing right before being able to press either OK or Cancel before I start a cut.

I’m using the firmware that was recommended by V1 in the install kit (little sheet that said "this item is not yet flashed. It’s easy: (and has a QR code that links to the firmware download site).

Any ideas?

Screenshot shows example of where touchscreen freeze happens.

My apologies. I mistakenly thought all cut attempts caused the lockup, and accordingly thought it did not matter which gcode file screenshot I attached. Upon closer examination, I think it was only one file that caused the lock ups, and that file name was too long! Again, the long file name is not shown in the screenshot above. Upon shortening the file name, the file lets the cut begin. I’m back in business. :slight_smile:


Wow. Interesting. Thanks for reporting back.

1 Like

I cant even get here. When i got to moce axis it freezes. It makes noises like it working but never leaves the screen. Ive got to wait about a minute and when it doesnt work got to turn it off ive got to ubplug and then plug back in. Its kinda frustrating. Was trying to do the crown test tonight and couldnt get everything in place to do it.


Share some details on your situation. Maybe someone here can help.

This is what I am referring too. Apologies I didnt think to take pictures. When I go to move axis. I can move one but when I try to go back the screen does this.

I had to reflash firmware for my LR3 board as it was flashed as MPCNC. Should I try reflashing the screen? If so do I do this from the screen or the board as I tried the SD card in the TFT but it did not do anything.

OK, so directly to your question: flashing the TFT’s firmware involves booting it with updated TFT firmware on an SD card that is inserted into the TFT itself. Note: TFT firmware and board firmware are not the same thing. Board firmware is a single .bin file. TFT firmware includes several things, such as a .bin file, a .ini file, and a folder named “TFT35.”

From a broader glimpse, I’ve not encountered the particular issue you are having. So, just spit balling here, issues with the TFT could involve a problem with the code used to compile the firmware, a problem with the writing (transcribing) the firmware into the device, or a wiring problem, or something else I’m not thinking of.

I pulled it from the V1 TFT page. Used the .bin, .ini, and the image ones. It took as the touch screen was updated with the current images but it seems that the screen freezes when dling the firmware flash to the TFT with the SD card. I let it sit for an hour as it was stuck on 97% then when i unplugged and plugged back it it was updated. Not really sure what the problem is. Not sure if its a wire, the screen itself, or something completelt different.

I wish I knew more of how to help. Maybe someone else will chime in.

1 Like

Probably not the same thing, but my screen/board would freeze occasionally. Read somewhere here that leaving sd card in could cause that. Removed sd card from skr pro board and haven’t had the issue since.