SKR Turbo LR3 - Z2 moves faster then Z1

So this is the issue I’ve trying to correct since I finished my build. My z axis just doesn’t seem happy no way shape or form. I’ve used the SkRTurboDualLR2209 firmware. Wired, rewired, dewired and what’s happening is with the normal setup for Z|Z1|Z-Max and Z2|E01|X-Max. The Z2 is faster than Z1. Endstops both function and stop the axis like it should. I’ve already tried M666 and they’ll align but Z2 will continue to be the track star.

I had them plugged with the Z stepper controlling both in parallel as well and they’ll move equally but Z2 endstop will trigger but not stop the axis.

I ran M122 and it shows this

Here’s silly idea: are the Z-drive screws and brass nuts the same? Did you reuse some material from some old disassembled machine.

Like I said, a silly idea, but I have so much stuff floating in my parts bin that it could happen to me (that was not a confession).


Yes, i ordered the kit directly from the V1 shop, only thing i didnt order from ryan was the printed parts and skr turbo with tft.

The Z2 says “bad response” and has all zeroes. That means marlin can’t talk to that tmc driver. Check the jumpers are the same as the others, and try swapping out the drivers to see if it follows the tmc (which would need replacing) or the port (which might mean an issue with the skr).

We have seen a couple of skr boards with soldering problems. They were pretty obvious when you looked at the solder pads. Some pins were just not soldered. On the skr pro, we were able to move to the extra port.

I think it’s gonna be the board then. Because it’ll say that z2 error whether I’m connected to the second z port or to E1. I’ve also replaced the drivers I have a few spares still brand new. So im just gonna have to send the board back to Amazon before the 30 day warranty expires.

1 Like

Did you double check the jumpers?

Looking at your first pic there appears to be something very different on the driver on the left . Two pins with cold solder joints and one hole looks like a piece of connector in it. That hole is empty on the other drivers

1 Like

yes theyre all set right everything is properly wired. i gotta wait on the replacement board from amazon but in the meantime im trying get this one to work. its running good with both connected to the twin headers. i just dont have the adjustment to the z axis. would it be better to just swap y1/e0 with Za/Zb as well as the endstops? i swapped the probe to the dedicated probe port and have z min logic reversed to match zmax. At least in my head thats what i think i did. idk i feel like i done went and learn vscode in a few hours because ive never been able to get past setting the env but all of a sudden i just redid a new config and got just 2 red errors on build :rofl:

I think it might’ve just been the angle or lighting because I have 10 2209s and non of them have look like the one in the picture. I made sure to cut diag pins. I stripped all the wiring down and tested for continuity from end to end. Everything works great except for that E1

Issue resolved. Problem was the board. Got a new skr 1.4 non turbo, recompiled firmware and everything works as it should.

1 Like