SKR Pro LR3 firmware Instructions

Hey all, Noob here. I have done a few mpcncs with ramps and it seems like everytime I need a larger one errfff! So I am going for the LR3 4x8 (shouldnt need more than that or I quit! That said, I cant seem to find a write up on step by step setting the SKR pro up through marlin or platformio. I am using electronic end stops. Any good info would be greatly appreciated

Welcome to the forum. Most people use Ryan’s preconfigured marlin firmware. I believe he has a git page were he has the changes he has made so you can compile your own


There is the docs page for the SKR Pro, has most of what is needed to get the wiring and firmware configured, if the stock V1 maintained firmware will do the trick.

You can get the binary file from the Marlinbuilder Releases page


At Dan’s “Marlinbuilder Releases” link, you want the firmware labeled V1CNC_SkrPro_DualLR_2209. This firmware is configured for TMC2209 drivers. If you made your build using a different driver, you will need to change the drivers in configuration.h

When you typed “platformio”, in your question, it was turned into a link. That link contains step-by-step instructions on how to get the firmware compiled using platformio.

After you get it to compile:

  • Place the firmware binary file on a FAT32 formatted SD card,
  • Make sure the control board is off.
  • Insert the SD card into the SD card slot on the control board, not the display.
  • Power up the control board.

If the flash of the firmware was a success, your firmware binary on the SD card will have the name changed so that it now has a “.cur” extension.

The V1 maintained firmware will not compile on Windows using the Arduino IDE.

No modern Marlin firmware will compile on Windows in the Arduino IDE. Didn’t want to leave the impression that this was a V1 limitation.

For practical purposes you are right. The reason I phrased it the way I did is that Jeff has mentioned that the firmware may/will compile using the Arduino IDE if some unnecessary (for us) files/directories are removed from the source. When the problem first occurred (i.e. Arduino IDE would no longer compile), removing files and placing the source at the root of a drive solved the problem. I don’t know if anyone has tested Jeff’s solution recently.

1 Like

It has been a while. That data was before the new IDE version of arduino too. I haven’t tried the new one.

1 Like

You guys rock. Thank you so much for the honest answers and lack of “try the search button” etc from much of the automotive snobs forums out there. So should I follow Robertbu in using theV1CNC_SkrPro_DualLR_2209 firmware flash?


If you deconstruct the name of the firmware:

  • SKRPro is the control board
  • Dual means dual endstops and is used for any build where each stepper has its own stepper driver.
  • LR stands for Lowrider
  • 2209 refers to stepper driver the firmware is set up for.
1 Like

Hey Everyone, thanks for the help. Its slightly funny how I skimmed over the super easy firmware flash section(literally install sd and power on) as I assumed it was going to be a bit more work like ramps/arduino. Anyhow, my rig is like 99% complete but I am facing a few issues.

Issue 1: I cannot figure out how to home it. I did use the firmware with dual end stops as that is how its setup however if i tap home on the touchscreen it just runs to the edge of the earth (usually opposite of the end stops)until it crashes into the side and grinds. Now I have to assume I have all my wiring in the correct polarity/direction as i did the “crown” test and its as perfect as my eyes can tell.
EDIT: I think I may have potentially found the solution to this. If i wait as minute after powerup it says no printer found. then this disappears and it seems to function correctly there after

Issue 2: About 4 of 5 times, if i power it on and attempt to move any axis though touchscreen (especially z) just to get to some sort of manual home, it grinds and shakes instantly like it is locked up or hitting a physical end stop even though it hasnt and i have to quickly hit reset. this can happen if the wires on a mpcnc are switched/opposite of each other, but on the 5th try i can hear the motors initialize(light humm) and they work fine. Now I have heard of faulty skr pro boards but this feels very janky and unstable compared to my mpcnc

Any ideas because as of right now this floating setup feels like 10 steps backwards from the mpcnc(no offense to anyone whom has helped the development just looking from outside in)

That is the sound of skipping steps. It isn’t the skr endstop trigger issue.

The most common cause is the machine is binding. Make sure you lube the Z screws and everything is aligned.

A loose wire or bad wiring can cause it. That’s annoying because it can be hard to find.

If the drivers aren’t configured properly (Ryan’s firmware at MarlinBuilder releases should), it can skip because the current is too low.

If the command is to move too fast (the default firmware limits in Ryan’s firmware should be slow enough), it can also skip steps. Stepper lose torque at higher speeds.

I can see that. And if that is your preference, no one is going to force you. Personally, I’ve found it to be very solid and once you load up the router, everything sits down just fine for CNC work. The milling really shouldn’t be pushing hard enough to lift anything up.

I did have an issue with a bad print and the gantry had toe out. That caused it to raise up on the rail and that was bad. Make sure it is tracking firmly first before you pass judgement.

I thought if I remember correctly the suggested drivers didn’t need to be adjusted for power like ramps boards do, as I didn’t not adjust them. hopefully I am not wrong on that. Lucky enough I went ahead and designed a full grid that also is numbered at every 100mm in SolidWorks, put it it through estlcam and was able to draw it on my wood surface. Luckily into my surprise it is exactly square I don’t even know how I did that so everything is tracking okay. When I say I don’t think it’s as sturdy as MPCNC it’s definitely not because there’s really nothing holding it down other than its own weight which is very minimal and getting it to track straight can potentially be somewhat of a pain I would imagine in just the way it works but I don’t think I would ever use this unit to do any kind of aluminum 3D milling like I would MPCNC which is much more rigid. Not today it couldn’t handle it though. That’s also not to talk down about the product because I think it’s a pretty nice design overall and I really like the fact that it pops right off the board and can be stowed separately from the base making it is easy as putting up a sheet of plywood when you’re done with it.