SKR Pro 1.2 w/ TFT 35

I am having problems with loading the software in a new SCR Pro board. It doesn’t respond to the Marlin screen and the TFT screen doesn’t move the servo motors,

I have copied the MPCNC SKR Firmware.bin file to the Micro SD card
and loaded it the board with and without the grey cables.
The file doesn’t change from Bin to Cur when loaded. Is there anything I can do?
What keeps a file from loading?

Did you purchase it from v1
Bc it comes installed. Also some board pics might help.
Does your tft say it’s connected to a printer ?

My original purchases were MPCNC machines with Ramps firmware. When they got old
and MPCNC no longer supported 3D printing I bought three new SKR Pro boards from BigTree to run the machines. I need instructions on how to load the software so each machine is identical and any problems will be the same…

1 Like

The microsd card needs to go in the skr pro, not the screen. In case that wasn’t clear.

And the skr needs to be reset after that, to make it check the sdcard.

So you have no v1 logo on the tft screen?
And have never got to the stage where it updates showing the progress?
I think you need more files on the as card I am trying to see.

You’re describing the update steps for the tft. The skr is a different processor with different firmware.

1 Like

I can send pictures but they are identical to the web site ones. Four power wires to the main and to the motors. Then x,y,z servos plugged into the drivers. Drivers and set per the SKR instructions and endstops are not installed. The tft says not connected until it’s cycled several times but then it seems to go away. But it is not predictable and seems inconsistent. I need help starting from scratch…

  • List item


I have flashed the skr with the Firmware.Bin file from the sd. I get the V1 logo on the screen
and the tft mode works but the Marlin mode doesn’t always work. What files should I put on the tft card?

What files should I put on the tft screen?
What files should I put on the skr board?
How do I test if the firmware is loaded?

The TFT is like its own little computer. If it is showing the fancy V1 logo, then it has been flashed with Ryan’s firmware. The “not connected” is a tad fickle. It is only on the tft side. Restarting doesn’t usually help, but it can take 15s or maybe up to 30s to connect. It should eventually connect every time (and I doubt it should ever take over a minute). The tft is like it’s own little computer, and it is trying to talk to the skr over serial. If that has a problem the tft still runs, but it says, “not connected”.

Marlin mode is different. In Marlin mode, the screen is just a dumb screen, and the firmware on the skr pro is what generates the images (like a monitor on a computer). If the info screen in Marlin mode says V1CNC v515, then you’ve flashed the skr pro. I would suggest using only Marlin mode until you get things more reliably set up, at least.

Marlin mode only uses the two 10 pin gray cables. TFT mode only uses the 5 pin black cable.


Thank you for your response it was very helpful. I am trying to synchronize three SKR boards that are responding differently. If I format a SD chip and copy the MPCNC firmware BIN file to it then put it into the SKR and flash it, will this update the firmware to the SKR and the TFT screen also? Or if the TFT mode doesn’t work do I have to flash it with something else? Is Ryan’s firmware set to 25000 baud? What communicates to the drivers? Mine don’t move in either mode…

will this update the firmware to the SKR and the TFT screen also?

The TFT has separate firmware. You need to use the SD slot on the SKR Pro for flashing the SKR Pro, and use the SD slot on the TFT display to flash the display. The display has its own firmware. Assuming you are using a display that matches the one V1 sells, you can find the firmware on this page.

Ryan’s firmware set to 25000 baud?


What communicates to the drivers? Mine don’t move in either mode.

I’m not sure what you are asking. As Jeff detailed, you should put your display in Marlin mode by holding down the knob for a few seconds. In that mode, you bypass the TFT firmware. If you execute a menu command in Marlin mode and it does not happen, it will have nothing to do with the display. You will have to look elsewhere for a solution. For example, if you did not hookup separate power for the motors, they would not move.

1 Like

Hi Bob,
I have tried some trials based on your input and wanted to focus on one board at a time.
Board A shows the marlin logo and the lft logo when I plug them in. They have no response to the Marlin comands or anything else. and if I push the reset button the screen goes blank and locks up blank until I unplug both wires. If I replug in the grey wires it will start again with the same results. I only get two yellow leds but get one green led on this board. 5 red leds.

It looks like your display is not going into Marlin mode. We have had a number of posts on the Forum about the gray cables not being plugged in correctly, and even not keyed correctly. Start by swapping where your two gray cables plug into the display and rerun your test.

I have tried the grey cables in all combos - the EXP 1 is power and connects the logos and when I connect the EXP 2 correctly it just sits there and if I reverse it (tongue backwards) it goes blank and grey. If I put in just the EXP1 power cable and then the plug in the TFT cable I can axcess the TFT screen but it doesn’t move the servos. The Marlin mode doesn’t work at all.

Do you know the significance of each of the yellow LEDs? I think they are the power circuits and my 3V is off. What does this control? It’s a new board and can I fix it? The fuses all look new and not blown.

For tft mode check your black tft ribbon on the left, make sure to have the single wire at the right place. (Look at MPCNC controlers documentation, it is well detailed)

Also check in tft configs that your bauds rate is set to 250000

There are a lot of open questions here. Let’s start with the LED. It is an indicator that your board has 3.3V power. All of your board’s logic is powered by 3.3V, so if your board does not have 3.3V, it is basically dead. I don’t have experience with this specific board, so my advice is more general ideas than practical knowledge.

The first step is to unplug all cables from your board. And see if the light comes on. Next, your board has a jumper that “decides” whether it is to be powered by USB or to use your power source. The first thing I would check is that jumper to make sure it is set to VCC and not USB. I’m not sure this would cause your problem, but it is something to check. The next thing to check is whether you have 3.3V on the board. Take a look at a pinout diagram and pick a gnd and 3.3V pair. For example, the endstops are powered by 3.3V. Carefully (you don’t want to short these pins) use a multimeter to check whether you have 3.3V on these pins.

If everything seems to be set up correctly, and you don’t have 3.3V, then I switch the jumper to USB, connect the board to a computer using a USB cable, and see if that changes anything. This would not be a fix, but it could tell you something about what is going on.

If you don’t have 3.3V power, then it is possible you either blew a fuse or killed the voltage regulator. Either can happen if you manage to short 3.3V to ground. Fixing the fuses or replacing the voltage regulator requires you to find replacement components, unsolder the old ones, and solder the new ones in. The fuses for 3.3V are not the large, replaceable ones.

If you sort out the 3.3V issue, we can move on to getting the steppers to move to make sure the board is functioning correctly, and then sort the display issues.

Edit: What is happening with your display is what I would expect if your board did not have 3.3V power and therefore Marlin was not running.

I am not getting 3.3 volts power and must have shorted the board. I am going to order a new flashed one. Thank you for your help.

My second board has three yellow LEDS and full power. The grey cables and the black cable are connected correctly. The screen has both the TFT logo and the Marlin Logo but the Marlin mode does nothing except printing MARLIN on the top of the screen but does not run the program… When you hold the knob and change to the TFT mode it displays but starts to refresh over and over again every 20 seconds. This prevents any further use…
Can you suggest what firmware I should use to reflash the screen and or the SKR board?
I just want to start with a clean slate with this new board. I can’t test the drivers or steppers because of the lack of Marlin connections.
Thank you

You will find a link to the firmware for the SKR Pro on this page. For a Primo using TMC2209 drivers, and with end stops, you want the V1CNC_SkrPro_Dual_2209 firmware. All you have to do to flash the firmware is put it on an SD card, insert it in the SD card on the SKR Pro board, and power up the board.

It sounds like you already have the right firmware on the TTF display, but if you want to reflash it, you will find a link to the firmware on this page. For flashing the firmware, you use the SD card slot on the display. There is some additional information about flashing both on the second referenced page.

As a side note, I suspect that Marlin is not running on that SKR Pro board. The V1 screen you are seeing is from the TFT firmware. That explains the screen going blank when you try and put the display in Marlin mode, and why the steppers don’t move when you send them commands.