SKR Pro 1.2 and TFT50. Works fine with non dual endstop but not with dual enstop

Hi. Im trying to configure Marlin 2.0
Got V1CNC_SkrPro_2209 and V1CNC_SkrPro_Dual_2209 from github

Installed first and later second version and both worked fine.

Now i tried updating my screen and for some reason only the non dual endstop version of the firmware works fine.

video of the issue

(non dual version works)

(dual version doesn’t)

What interesting. I can still control the motors using TFT screen. So screen is talking to the SKR. But the SKR doesn’t seem to be talking to the screen

Working soft (non dual)
144035464_439643103746007_5723061075131408464_n !
Not working (dual)

using the terminal on the screen

This might seem like a stupid question, but do you have duel endstops and all 5 stepper drivers installed?

I had 5 motors connected this morning when I tried to run MPCNC, but had not connected the endstops yet.

Should I ?

I have now taken the SKR home to try to solve this problem.

It’s always best to have the hardware installed yes. Are you using the screen in Marlin mode? I know the tft firmware is still in development. To switch press and hold the knob down for 10 seconds

It looks like the screen is querying marlin for status when the SKR PRO is turned on.
On software without double endstops there is definitely more of this while on software with double endstops practically nothing happens. Additionally, it keeps displaying the command “RCV: ok T:0” over and over again.

Terminal after bootup with non working dual endstop

Terminal after bootup with working non dual endstop

@Atom I’m using touch mode

i’m not an expert with the TFT (actually i haven’t even used one) or the firmware, but i have heard a lot of people have issues with it in TFT mode. try switching it to the Marlin mode and see if you still have issues, if not then at least we know it is in the TFT firmware and nothing is wrong with the board, your wiring or your boards firmware.

Got it working… seems like new TFT firmware NEEDS atleast 1 extruder data (probably info about temp or something)

Changed it to 1 and it worked

interesting, thanks for letting us know, @jeffeb3 or @vicious1 somthing to keep in mind the next time your in the TFT firmware :slight_smile:

1 Like

Our tft firmware or the current BTT branch?

That doesn’t look like the v1 tft firmware. It doesn’t show the v1 logo and it still shows all the printer menu stuff.


Hah shows how much I know about the TFT XD

Is the latest firmware from the big tech tree github site.

They changed that you need to have atleast 1 extruder (ext_count:1)
And stock dual endstop firmware uses 0 in marlin. So screen keeps waiting indefinitely for info about that extruder

I didn’t find earlier that there is a firmware version for TFT from V1 :sweat_smile:

I’ll check right now, but it will probably be fine

oh. there is only tft35 version and i have tft50. guess i will stick to firmware from Big tech tree :sweat_smile:
Good thing that it works now