SKR 1.4 Turbo - Only 1x Z stepper working when homing

Hey guys, setting up my Lowrider 3 with a SKR 1.4 Turbo / TMC2209’s. Using the Marlin 2.1.1 firmware found on the V1 MarlinBuilder github, except I am compiling it myself.

I have the X and Y axis working and homing correctly.

Z axis is working correctly, moves up and down when you use “move axis” fine. However when homing it is only turning the right side (xmax end, connected to X1 driver) stepper motor. The left stepper (at xmin end, connected to E1 driver) doesn’t turn but it is active (I cant turn it by hand while its trying to home).

Endstops are all working fine including the probe input, all report “open” with M119 and all report “TRIGGERED” when I activate them with my finger.

I have swapped drivers, swapped stepper connectors around (so the other end moves instead), and found its definitely a firmware issues since “move axis” works fine.

I cant see what it could be. Z2_DRIVER_TYPE is defined. Z_MULTI_ENDSTOPS is defined and appears working with M119. Unless someone has any ideas my next thing will be moving all the V1 MarlinBuilder changes to a fresh copy of Marlin 2.1.2 and seeing what happens.

Thanks in advance

Tried it with the latest Marlin bugfix, still exactly the same problem.
I have opened an issue on Marlin github

From your github issue:

Reporting endstop status
x_min: open
y_min: open
y2_min: open
z_min: open
z_max: open
z_probe: open

There should be a z2_max. Did you make any changes from the duallr version on MarlinBuilder releases? The skr pro version definitely works.

Also, I just want to confirm your Z2 is connected to the E1 output?

Someone on github found my mistake.

Since Z homes in the positive direction, Z1 uses the ZMAX endstop (not MIN as the other axis do).
So for Z2, I need to use ZMIN endstop (or I could use XMAX if I wanted to, as that one is also unused).

Tried that and it compiles and works perfect. I feel like an idiot


In the V1 firmware, Z_MIN is used for the Z probe, and X_MAX is used for Z2… just saying…

I did notice that. The SKR 1.4 has a seperate probe plug which I will use instead.

Had the same problem for the SKR 3 EZ. This is it. U could use Z-min and max to if you won’t and use the probe pinout for the probe. Works fine for me.