Silky curls

So I was printing fidget spinners for a couple of young girls yesterday and I decided to give the silky red from Ziro a try. They came out looking really nice in general, but with a gotcha or two. I then printed a calibration print to see if I could figure out what’s going on. Note the corners are curling up a bit, as if it’s extruding too much while turning the corner. Possibly an artifact from not retracting when slowing down to reach a corner? How would I fix that if so?

[attachment file=40811]

OK, I measured the final results to decide if I needed to tweak any of the basics.

X, requested 100mm received 99.8mm -> adjust steps per millimeter from 200 to 200.4

Y, requested 100mm received 99.7mm -> adjust steps per millimeter from 200 to 200.6

Z, requested 50mm received 48.8mm, but with the elephants toes very evident. I then measured Z from the top of the X and Y components (5mm up) to find what should have happened if the first couple of layers weren’t so smooched. dZ, requested 50mm received 49.3mm -> adjusted steps per millimeter from 788 to 799.19

I saw some delamination when putting side pressure on the Z component, so I’m guessing I need more tweaking to account for the current 0.5mm nozzle I’m using. My calcs say with 0.5mm I should see 0.60 wide and 0.417 tall extrusions (assuming a true ellipse and no expansion of the plastic when leaving the nozzle), I think I’ve still got that set to 0.48 and 0.33 in my current settings, so correct for 0.4mm nozzle but light for the larger one. It should be just under extruding by 20% or so, but that’s not what the corners look like.

I switched to 0.5mm on the nozzle a few days ago to help minimize the stringing caused by the bowden tube’s slow reaction to changes in extrusion pressure, along with the 5mm retraction setting I found was working best.

I’m not completely clear on what you are having issues with. from the bed it looks like it wasn’t hot enough to stick, and the top of the print looks slightly over extruded or just too hot. I have no idea why that corner looks funny.

I have not really calibrated a printer that way I use the actual machine instead of measuring prints, I move the x, y, and z 100mm and verify with calipers and then do an extrusion test and verify it moves 100mm of filament from testing the cold side of the extruder. If the steppers are working correctly I feel pretty good about it.

I would never do a layer height of more than 80% the nozzle diameter and usually do 65% so I get a good 45 degree overhang. As for your extrusion width your slicer isn’t calculating that for you? I don’t remember those numbers I don’t think I have ever not used default settings.

That filament looks amazing and the straight parts are spot on.

I reprinted the calibration piece and it now measures spot on to the limits of my calipers in all three dimensions. I’m still seeing a little bit of overextrusion at the corners. I’d really like to understand for sure what’s causing it. Right now I’m still hypothesizing that it’s not retracting when deceleration starts when entering a corner. That could easily be the slicer, though it’s as likely I’m just not figuring out what to change in slicer parameters.

I just finished printing another fidget spinner to see if the bearings now fit tighter with the new calibration. They were just barely loose before, but fit perfectly using the regular red filament (which doesn’t show the artifacts at the corners). Once the bed has cooled I’ll check it out.

The layer calcs are assuming a ellipse 20% wider and 20% shorter than the nozzle diameter. Anything under 20% requires the slicer to slow extrusion to compensate for the lessened cross section area. That’s not an issue with quality, but does slow you down slightly. When I started testing this particular print I used pretty much the defaults as documented here. It was a bit over 30 minutes and gave really nice results. The one I just finished took 16 minutes and very similar quality.

[attachment file=“40833”]

It doesn’t retract when entering a corner, it just extrudes less.

The acceleration is controlled by the firmware (Marlin) not by the slicer, so the slicer would have no way of knowing how slow the firmware was going to take a corner. The slicer tells the firmware how much to extrude by the time it gets to the corner, but it can’t control how fast the firmware executes that move.

If it is a speed/extrusion issue, then the problem is that the pool of filament has too much built up energy (for lack of a better word), so when the firmware slows down, the extrusion takes longer to slow down than the print head takes to slow down.

I’m not an expert printer, so I don’t know what’s wrong. I am only poking holes in your theory, sorry. I would make sure you’ve got the temp set right. It looks like maybe a hot print to me.

<p dir=“ltr”>What is your extrusion multiplier set at?</p>

Extrusion multiplier is set to 1.

If it is a speed/extrusion issue, then the problem is that the pool of filament has too much built up energy (for lack of a better word), so when the firmware slows down, the extrusion takes longer to slow down than the print head takes to slow down.
This is a likely scenario, especially with the bowden tube in place. There are a bunch of EEPROM setting I don't fully understand, perhaps one of them would tweak it to work better. There are a lot of bowden based printers, so I expect it's been dealt with. I just need to figure out how.

Maybe increase the jerk and acceleration, and decrease the speed. At least for a test. The increased accel/jerk would make it take the corners hard, but the extrusion wouldn’t be a problem. The decreased speed would make the extrusion speed lower as well, which would mean there was less energy.

Yeah, I can get darn nice prints by slowing things. What I’m trying to do here is figure out when I can fly, when to take the train, and when to just grab a backpack and hike. :wink:

I’ll try setting jerk and acceleration to see how it affects things.

This one really, really breaks at speed…