Screen stopped turning on

I finally got my machine to home successfully in the X direction when suddenly the machine stopped turning on the screen. I’ve checked all the connections and they are snug, and I believe correct. The light on the SKR Pro v1.2 ( is turning on when I plug in power, however I now get nothing on the screen.

I’m using this screen:


First determine if the SKR Pro is iperating properly. Try to connect to it using the USB serial port, and do soma basic queries, M119 and M122 are useful. M119 willcheck the end stop status and M122 will go over the status of the TMC drivers. By doing this you will get a good idea of what is working.

Note that the TFT depends on the 5V bus. If you connected your stop switches wrong, you could be shorting the 5V bus out, which would do bad things. Check the wiring guide and be sure that your stop switches are connected to only signal and ground, not to +5V

You said this happened when you homed the X axis, does it work if you moce it away from home? That would be more evidence that you mis-wired the stop switches.

I just completed my build with that controller and screen. I lost count of how many times the screen blacked out during the testing phase. I found that screen connections are super finicky. SERIOUSLY! Try unplugging them and reconnecting them.I also used a zip tie to secure all 3 ribbon cables and use it as a strain relief before they exit the box.

FWIW, these cables were a welcome replacement from the grey ones included. They are a bit longer and match the length of the black 5 wire cable.

Possibly my ignorance, but i’m not getting any response when i try to send gcode to the board using cncjs or repetier-host. Both apps report a connection has been made, but no response comes back when I send those commands.

On my Mac:
My Mac showed connection made, but I could never get Repetier to actually connect. But I could get CNCjs to work with a Mac.

On my PC:
Using the USB-B to USB-A cable, connect the controller board (not the display board) to your PC.

In Repetier-Host, use the following settings in Config->Printer Settings on the Connection tab. And set the Com port to whatever Windows assigned to your board.

You should be able to send gcodes on the manual control tab. Make sure to use UPPER CASE commands. Official gcode does not recognize lower case.

You should also turn on commands in the log to be able to see both sent and response commands.

Dave, thank you so much for the detailed instructions! I’ll confirm I’m using the right settings and report back.

I’ve now tried repetier on Mac, which claims its connected, but reports communication timeouts. I’ve also tried CNCjs on mac, which also claims its connected, but does nothing with anything manual commands sent, or by using the buttons. Is my board dead? There’s a light when I plug it in, the screen isn’t working (including with the cables you linked), and the usb plug also has a light.

Try this on your Mac. Connect the USB.

Go to Apple->About This Mac
Click More Info…
Click System Report
Click USB

I see this when the board is connected:

With that, you know that the Mac recognizes the port

Open CNCjs and use the Connection widow.
Select Marlin
Click the reload button (2 spinning arrows) next to Port
My board connects as /dev/tty.usbmodem3966306933311

You can enter GCODE commands in the Console window