Replacement/redesign Y axis motor

I replaced the two Y axis motors and belts with one motor and a lead screw. It does move in manual. My problem is that when I tell it to move 50mm it only goes about 13mm. My new motor is 200 steps/rev and the lead screw is 12.5mm/rev. I’ve set the default steps/mm from 16 to 400 and still it never goes more than 13 mm at a time. Am I missing something here? I’m using a Rambo board, Arduino1.8.13 , Repetier-Host V2.1.6. Windows 10. Thank you.

What microsteps do you have set?.. The motor will be 1.8degrees per step making 200 steps per revolution but your controller is probably outputting either 8 or 16 microsteps.
You can work out the steps per mm by using this formula…

Steps per mm = 360 divided by the degrees per step of the motor multiplied by the microstep setting divided by the pitch of the leadscrew…


16/12.5 = 1.28

200 x 1.28 = 256
How have you setup this one motor to drive both gantrys? could it by driving so far and then getting jammed?

Thanks I’ll try that formula. I run the lead-screw down the center underneath my table. I attached one piece that goes from side to side and that moves the gantry up and down. I did run it from one end to the other by hitting the manual move button many times. It does go smoothly.

Thanks again. It took awhile and several attempts. Finally I went into Repetier host and configured the Eprom setting to 256. That worked. Now my Y axis moves exactly as it should.