Repetier -Host Issues

When I save my files from Estlcam and import into Repetier-Host, the design displays all garbled with circular lines all over. Any idea what I’m doing incorrectly?

Newer versions of repetier host have something wrong with the arcs (G2/G3 commands). It is a display bug. I’m not sure if anyone has reported it to repetier, but it still works when the commands go to Marlin.

My guess is they are drawing the wrong part of the circle. They are going clockwise instead of counterclockwise to get from start to the end point.

As a workaround, you can install an older version of RH, or use another program (like cncjs, or pronterface).

I’m seeing the same thing, but when I try to send it to the machine, I’m getting an unrecoverable exception error.

The RH log is throwing:
System.NullReferenceException: Object reference not set to an instance of an object.

I’ll try again tomorrow, and if I get the exception I’ll screenshot it and post it here. Meanwhile I’ll grab an old version of RH and see what pops.

As a temp workaround as Jeffeb3 noted, version 2.2.2 seems to work fine.

1 Like

Thanks everyone - going to download 2.2.2. :slight_smile:

I’m experiencing this too. :neutral_face:

I have tried making new files with EstlCAM and with InkScape, but the same mysterious circles appears when opening the files in Repetier Host.
I have noticed that it’s only when I have some kind of round or curved surface in the file. A file solely containing “TEXT” works fine. :man_shrugging:

I have tried all three versions of Repetier that’s available for now, 2.2.4, 2.2.2 and 2.1.6.