RAMBO 1.4, IoT Relay and M106/M107

I’m trying to utilize the IoT relay to power my router via the Fan 2 port on my RAMBO. (FAN 0 comes on… more on that below)

First, I know absolutely nothing about coding (I had to buy the RAMBO with the pre-loaded firmware, haven’t been brave enough to touch it).

What I’ve done:
In ESTLCAM, under “CNC Programs” “Texts” “Laser, Plasma, Water Jet, etc” I’ve added M106 to “Start Cut” and M107 to “End Cut”, results left the “FAN 0” pins on the RAMBO 1.4 powered (12.2V) from the start of the gcode, but it never turns off

I’ve tried M106 255 to “Start Cut” and M106 0 to “End Cut”, results were that the “FAN 0” pin was powered (same 12.2V) at the start of the gcode, and powers off when the job is done… but it seems that the pins lose power during the cut, almost like the switch is turning off when the tool would be moving from one cut to another (I can see this being beneficial for a laser attachment)

What i assumed would happen:
The things I’ve read have indicated that placing the “M106” or “M106 255” would power the pins for FAN 2 and provide the full 12.2V for the IoT Relay, and that “M107” or “M106 0” would essentially kill power for FAN 2.

So, what am I doing wrong? I’m ok with using the pins at FAN 0 (I will use the proper connector, and not the one pictured), but how do I use M106/M107 for the router?

Thanks!

Gcode isn’t magic. The only way estlcam can control the fan is through M106/M107 commands. So if it is turning off during cuts, then there must be more M106/M107 commands in there.

Long story short, check the gcode for M106/M107 and then try to find the estlcam setting that turns them off.

1 Like

I should clarify, it does not shut off as it’s cutting. The “switch” will turn off during the travel from one cut to another.

But I’ll look into it a bit further, thanks!!

Also, I discovered that if I add a P2 after the M106 or M107, it then references the FAN 2

Another update… I realized that the M106 and M107 should be under the tab “Texts” --> “Program Start” and “Program End” (respectively)… and NOT under the “Laser, Plasma, Water Jet, etc” tab… makes sense now!

So, now that I have that knocked out and it turns on/off when its supposed to, i just realized that the RAMBO 1.4 outputs are all DC and the IoT Relay input/switch is AC… I cant win!

What is everyone else doing for the RAMBO?

The iot relay should trigger. Try using half power.

1 Like

Jeff, thank you for the quick replies

I tried dropping it down to half power (M106 S127) and ran the code. It immediately caused the IoT to trip the breaker and reset itself.

Wouldn’t the fact that the IoT input is AC cause this to happen no matter what voltage (DC) it is set at?

https://www.digital-loggers.com/iotfaqs.html

Q: How much current does it take to trigger the control port?
A: About 0.2mA, the input is constant current. 12-120VAC or 3.3-48VDC will trigger the relay. DC trigger input is polarity sensitive.

1 Like

Take those commands out of the laser, plasma, waterjet, put them in the program start and program end. You don’t want the laser, plasma, waterjet running during moves(makes funny lines in your stuff), so it turns them off.

1 Like

I remember that thing accepting almost any input I gave it. But it was a few years ago now, so I’m not sure which way I had it.

From what Barry posted, it should respond to the DC trigger too. So full power should be fine.

Half power isn’t really 6V, your meter is averaging 12V and 0V and reporting 6V. If you put it on an oscilliscope, you’d see it flip between 12V and 0V spending half the time at 12V. I thought that might work better because it is close to a 12VAC signal, with a 6V offset.

Do you have the rambo plugged into the IoT relay? There are two ports that are on when there’s a signal, and two ports that turn off when there is a signal. I think you got it to work, which unpowered the rambo.

1 Like

This point is important to keep in mind. The SSR that I use in my setup is also polarity sensitive. If I hook the signal wires backwards, it does not work. They have to be hooked up with the signal wire to + and the ground wire to -.

I can’t believe it was that simple, really goes to show that my wife is right and I need to wear my glasses more often.

It says on the IoT “Normally on” and “Always on”… I had the Rambo plugged into “Normally on”, so when the switch was activated it turned it off.

Thanks again V1! I’m learning, day by day

1 Like