Not able to Control in TFT mode / "No Printer Connected" error

Hello V1 / MPCNC Hive mind!

So after some digging on the forums I have come across a couple of threads where some people have been having trouble with their control boards and getting an error that says “No Printer Attached”. In all of the posts that I have seen it appears that reloading the firmware sometimes resolves this issue. I have tried this both for my board and screen with no luck.

My current setup is all from V1 store, and I am using a SKR Pro 1.2 and a TFT35 E3 V3. From what I have tried I think I have followed all of the correct steps in both the flashing of the firmware for both the board and screen. I also have checked my hardware for some other issues and to the best of my knowledge everything seems to be in order. I am able to control the motors through the Marlin side of the control, but not with the touch screen. I am able to get into all of the different setting and menus, but am not able to control any of the hardware.

If anyone has found a solution to this or know; thanks!


There are three cables connecting the display to the control board. Sometimes the issue is in the third cable…either missing or not connected correctly. Also sometimes the issue is the baud rate between the display and the control board. It should be set to 250000.

Are you talking about the split connector cable(4 pin and single pin)? I have checked that and I think I have it securely in the board. I should be getting some JST connectors in the mail tomorrow and am going to try and redo the connection.

I also have checked that baud rate and it appears to be set correctly. Should I be checking both the SKR firmware or should I also be checking the display files too?

The baud rate is hardcoded in the firmware for the control board. You need to check the baud rate of the display. I don’t have an SKR Pro, but from reading about this issue, there is somewhere in the display settings that sets it to 250000. You shouldn’t have to reflash the display to check/change this setting. Here is a picture of someone else who was having problems. Note the five wire connector in the upper right that connects to the display port. Earlier pictures had a black 5-wire ribbon cable. There were some complaints about the black ribbon cable.

1 Like

That appears to have done it! Thanks for the link to the other thread Robert! I was curious what that extra bundle of cables was in the box. There was no documentation on it in the assembly instructions so I was not sure what it was for. This seems to have resolved the issue. Thanks again!