No M00 pop up message

I have been playing with tool change code and am simply playing around with resetting after M00 is sent.

  1. Using the terminal feature on the TFT I can send M00, this generates a pop up on the LCD with a button that I can use to resume. Great!
  2. If the M00 is sent in repetier or in Cnc.js via connected laptop there is no message that comes on the LCD and there is no way for me to re-start the program.

I did read that using cnc.js you have to unpause using the TFT AND the program but it seems i cant get a pop up on the screen at all if M00 is sent via connected laptop.

Any ideas?

Try sending an M108 command to break out of the pause. As a more remote idea, you could play with an M226 and a button to change some specific pin on the controller. Either by firmware or through a wired resistor, you’ll have have to set the normal state of that pin high or low instead of floating.

M108 and M01 commands don’t work, when it gets into the “pause for user” state, it seems the communication is too busy to be able to snap it out of it. I can type it in through the TFT but it does not react or accept any requests through the terminal

I guess a better place to start would be, does anyone else have this issue or do you all get the pop up on the TFT when sending an M00 code through repetier or CNC.js?

There is a difference between the tft and the lcd. The lcd acts the same as the tft in “marlin mode”. If you were using that, then you would see the message and be able to resume it.

I’m using the tft35 that’s sold with the SKR kit. I am running it in the non-marlin mode. If I hold down the button it gives me the option to choose marlin Mode. When I do that the screen just goes black and it says “(bunch of numbers) simulator” and i can’t do anything but return to the other mode. I don’t have my grey cables attached though as it would not work originally with both attached. Could this be an issue?

Yeah. The bunch of numbers simulator is the one that gets the pause message if the M0 command made it to Marlin. I think the issue with the gray cables is they were in the wrong way. They worked in my testing.

Do I need the grey cables to use the marlin screen or is that all I’m supposed to see?

I will try to grey cables again when I’m back at the machine. I had triple checked orientation to the images in the instructions on the v1 website but anything is possible

The keys on those cables are sometimes wrong. It is a recurring issue here. So sometimes they need to be flipped. There are probably 4 people I have told to unplug the gray cables to get them rolling. I haven’t heard back from anyone that got it fixed by installing them a different way. So if that works, let me know and we will tell people to turn them around next time.

Marlin doesn’t know what it is talking to. It thinks it has the old bunch of numbers display attached on the gray cables and something is talking to it over serial. The something is the screen, but ti Marlin, it might as well be octoprint or repetier host.

The screen is either in a sort of “smart” mode where it sends over serial, or the bunch of numbers display, where all the buttons and drawings are handled by marlin over the gray cables.

TL;DR, the grey cables are for marlin mode. The black cables are for touchscreen mode.

Perfect I will give that a try. I was one of the people that didn’t get up and running with the grey cables attached. I thought I had an issue so was trying to upload the firmware to the screen but it would never get past 14% with the grey cables attached. I will look closely. I had aligned them based on the red line on the cables but I will play with it when I’m back at the machine.

So I got it up and running, it actually works in both modes but in the “big tree” mode I don’t get a pop up. In marlin Mode it gives me the notification at the bottom of the screen. Clicking the dial indicator gets everything running.

The first time I installed the grey cables it would just freeze and not go into marlin Mode at all. (This is was the problem originally). Then what I realized is the cables are backwards. Idiot!. In the image the numbers 1 - 1 and 2 - 2 don’t indicate the two different cables which is how I originally read it at first glance. I noticed on the board it says exp1 and exp2 and I just matched those with the corresponding ports on the display. Then it all worked at which point I realized I was reading the instructions wrong. The image actually shows each end of the grey cable being 1 and the other 2. I could very well be the only one that read these instructions incorrectly but I suspect it’s what’s causing a lot of the issues that I was seeing.

This is how I thought it was presented when I first looked at it.

1 Like

Hmmm. Yeah, that picture (from the docs) doesn’t make sense. @vicious1, did you make that? Am I just seeing it out of context?

And thank you for reporting back. The next person with this problem will appreciate it.

No problem at all, I have had a lot of stumbling blocks getting this thing dialed and you guys have all helped me through them so it’s the least I could do to help.


HAHAHA shows how many people follow the instructions!!! (at least the wires are show correctly)

BUT…your pic is backwards as well (1=2, 2=1). Mine is mixed up. This is too funny.

Thank you so much for catching that I will try and fix it ASAP.

Haha fair enough, I didn’t think the numbers corresponded to anything but now that you mention it, your selection of 1 and 2 might be paired with the exp1 and exp2 on the board. I just scribbled numbers on my phone to show how I would have layed out such a drawing. Glad I could improve the instructions at least :slight_smile:

1 Like

Finally fixed it.

1 Like