No can move

I keep thinking I’m missing something obvious. I hooked up the electronics today. I used a repaired Mega, a repaired RAMPS and two new DRV8825s with a 6A 12V supply. I set the drivers to 0.70V with no motors then powered it down and connected the two steppers, the limit switches and the USB. Fired up Repetier-Host and connected to the boards. Everything looked good to go, but when I tried moving nothing happened. OK, I swapped out the Mega2560 for a new one, just in case I’d screwed up the repair. Same thing. So I swapped out the RAMPS for a new one. Same as last time, no movement. OK, maybe it needs the display connected. Nope, display looks good, right version of Marlin for the ZenXY. No movement either with the display or from the PC. Rechecked the driver voltage, it’s still good. Finally grabbed a new stepper from a different vendor and no joy with it either. I am either missing something obvious or maybe I’m just going crazy. :wink:

Stepper and limit connections [attachment file=43081]

RAMPS and Arduino [attachment file=43082]

Display shows normal [attachment file=43083]

Repetier-Host looks good [attachment file=43084]

The limit switch connection doesn’t show well. Harness wires are green black red and connected to the RAMPS at S - +. Limit switch is NC and connected between S and -.

When I ask for a +50 move in R-H, the display says it’s at 50, but nothing moves.

Bummer. Maybe the endstops are wired wrong? Even if you didn’t flash the right firmware, I would think it would be moving in some direction.

There’s a command to see the state of the endstops. M119 I think? If you run it on the serial console, it will print the state of the stops.


1 Like

Just tested, the m119 command works slick. They are open when in normal operation and triggered when I click the switch, so just as expected.

Unless you have weird switches, you don’t use the limit + pin. Just signal and -. If you hook up +, you fry the voltage regulator. I just did this last week… Good news is I still remember how to solder! Have three spare boards now.



Wait. Just reread your post above mine. They should be normally closed, and open when clicked. That way the machine stops if they come loose for some reason.

I assumed triggered meant the NC switch was open… But to test I held both switches and tried to move. Nothing.

Try unplugging the usb cable and then move with the screen dial only.

OK, gave that a try. no difference except the display was dimmer. Figuring there might be an issue with the cheap supply I swapped it out with a 30A supply earmarked for my next MP3DP. The display now didn’t dim when the USB was disconnected, but no change to the symptoms.

Going back over my steps I realized I hadn’t swapped the drivers, just assumed since I could set their voltage that they were working. So, I swapped them out and calibrated a second set and … I have movement! :slight_smile: