New Firmware 515

Update to Marlin 2.1.1, Release Marlin 2.1.1 · MarlinFirmware/Marlin · GitHub

Highlights since v513 (514 was skipped (git issues))

SKR Wifi changes

  • The default is now TFT MODE. Marlin mode will no longer see the SD card in the side of the screen TFT mode will.
  • 8266 Wifi added to the board, not the TFT. This will let you run in headless mode.

Laser updates

  • Inline laser commands. 8bit can do 22mm/s raster, 32bit 25mm/s raster. Vector much faster.

Driver updates
MP3DP v4 initial release

New TFT Firmware

There is a new release HERE as well.

Still working on a few tweaks and configs.


Defilitely excited about this.

I added the wifi to the TFT because it seemed better with the older Marlin (did not need the extra on-board serial port enabled) not entirely happy with the ESP8266 firmware yet, looking forward to this being better!

Does the TFT need the grey cables for SD card access? Is Marlin mode still available?


Using the 3rd port now so we can do this without the expensive screen if we want.

The 3.0 of the espui/3d is pretty functional. I’m going to run it a bit more and decide which to preload.

In marlin mode, yes. In tft mode, no. The screen itself reads the card in tft mode and plays the gcode through the serial interface.

1 Like

This is awesome! Going to try it tonight!

1 Like

Also looks like you sized it for a full size bed from what I can tell. 1220mmx2440mmx200mm. NICE!!

1 Like

Yeah, I am going to start pulling some safeties. I think I am causing more issues than helping so I am starting to speed things up as well.


Installed and everything went well. No issues that I can tell yet in just basic movement and homing. I like having more of a CNC centric display!

1 Like

Thanks for checking!

I installed both, no issues so far. esp wifi can be used from the display or the board, which is handy. Nice icons on the display, but I do miss the popup saying which IP address was found, but no biggy, and I don’t see the t2209 step modes option in the settings to enable steathchop, but I just M569’d the lot and saved to eeprom. M3 and M5 worked for me to turn the router on and off, saves me a compile.

So… good job. :slight_smile:



I still can’t seem to find a copy of this that I like. I keep getting jammed up with 8.3 filename BS. Honestly it’s the main reason that I switched the LR from the SKR to the Duet.

There are a few options for pop ups in the config. I have it set to popup and go away I think. If you want to verify the better setting I can change it.

I need to check but I think v3 shows more letters. I have gotten pretty swamped, and I have not messed with it in a few days.


Yes it does, [DISCUSSION]New UI 3.X · Discussion #94 · luc-github/ESP3D-WEBUI · GitHub

1 Like

Status =1 in config.ini to get the notification area show up and only with wifi on the display. The other notification options looked to be enabled. I just have to enable wifi in the ports settings and set it to 250000.


I will look into that. The goal is not to have a display so as long as that does not interfere with anything.

I ran into a strange thing today with the new firmware. I was lowering my Z axis by 10 but it didn’t stop at 10 and bottomed out. Almost like I set it to 100. It was previously homed so it was at max height. I did a double take looking at the setting before killing power to make sure it wasn’t set to 100 but it was set to 10. Could have just been a fluke because I could not get it to do it again. Weird… lol

Were you using repetier host? It keeps its own record of position and it gets it wrong.

Easy A axis with this firmware, could probably just keep it in as default, but I added stealthchop and set Z max to 75 and I guessed the settings for angles/min etc, so probably wouldn’t be square, just wanted to see if it would work. I attached the changed files, configuration and configuration_adv, and I updated sanitycheck to ignore the lack of I (letter eye) endstops (commented out). Mostly added an extra to all the array definitions and turned things on, it auto assigns to E2, that was the hard part, not knowing that and spending forever looking for a pin assignment. Just keep fixing the first error that comes up seems to be the go to strategy.

EDIT: fixed steps per unit to be 9, seems to give me 90 degrees with g1 A90, if that is what ends up being what works instead of mm. (130.1 KB) (110.2 KB)

This is what I get with a G1 X20 A20 command (or did).


I was just using the tft screen.

The endstops only function during homing, You can move past them regularly.