MP3DP R4 TFT Screen Update Issues

So I have been running Marlin mode on my TFT35 for the Repeat V4 since I built it and haven’t really thought to switch to TFT Mode until just now. So I held the button 10 seconds and switched. Everything worked fine. Then I noticed that my screen was all black and white only and seemed outdated, because everyone else was using a nice colorful screen. Being the human that I am, I wanted the colors.

I went to the V1 github and pulled the latest (I think) TFT Firmware. I copied the following files over to an SD Card:

TFT35 (folder)

I inserted the SD card into the screen and everything updated nicely. The screen is functional but I am getting “No printer attached”.

I have tried to decode the issue by reading some other forum topics from the past on this subject but there seems to be a different scenario on each topic I read. Hopefully someone can direct me in the right direction to get this corrected.


Check the baud rate on the screen. I’ve had that happen before. Should be 256000

1 Like

Well gezzz, I don’t think it could have been any simpler than that…



LOL I felt the same way when I posted about mine. Glad it got you fixed up!