More Detail on Initial Firmware

Hi All,

I have experience with BTT boards on (5) 3D printers but bringing my MPCNC up is causing me some problems and I haven’t been able to find the level of detail on the main build page or searching so just wanted to dig in on a few topics.

  1. Firmware: for the SKR Pro V1.2: I downloaded from the github repo (Releases · V1EngineeringInc/MarlinBuilder · GitHub), I unzipped and copied firmware.bin to the microSD card, inserted into the SKR Pro and verified that the file was renamed to firmware.cur after a power cycle. Are there any other checks at this point to confirm successful?

For the TFT, I downloaded the BIGTREE_TFT35_V3.0_E3.27.x.bin, config.ini, and the TFT35 directory from the repo (Releases · V1EngineeringInc/BIGTREETECH-TouchScreenFirmware · GitHub), I placed all of these on a SD card and plugged into the side of the TFT screen. EXP 1/2 cables are disconnected from the SKR Pro and everything was powered up. The screen had a message at the top of “Card Detected” but otherwise I don’t see any indication that it was reading or flashing anything. There is no v1 logo screen or no CNC type of content – all of the touch screen content appears to be the default 3D printer content. I pushed both the reset button on the SKR pro and on the TFT with a repeat of the above but nothing obviously different Did I do anything wrong with these steps and how does one verify if the screen was correctly flashed?

  1. After performing the above, I powered down and reconnected EXP 1 and 2 to the SKR Pro per the picture on the v1 build page (SKR Pro - V1 Engineering Documentation). I applied power and I see the “Printer Not Connected” message and otherwise the screen display is in the same state as the above. I am confused about the note “You do not need to use both” and wasn’t sure if that was referring to touch screen and knob mode, or the connection of the cables. My connections look like those shown in the picture with both grey cables and the black cable.

  2. Repetier Host (for Mac): I downloaded the image and ran the program. I left all settings as is other than changing the “Port” to usbmodem and tried baud settings of 115200 and 2500000 under printer set up. Prior to changing the baud rate, I was unable to get a connection. I do get a connection using either of those baud rates, however I do not get any motion when I click on the buttons, I don’t see any gcode in the terminal display and I see a message stating X commands waiting in the top box of the Repetier interface. On my SKR Pro, I have power to both the main and motor input terminals, I have all 5 stepper motors connected, I have all endstops connected (NC configuration), and I have the screen connected as above.

Thanks for any help with that! One step at a time will be fine or maybe some experienced pros could knock all of that out with one reply. :wink:

Update to my own post: I was unable to get Repetier working yet nor the TFT35 in touch screen mode, however when I switched the screen over to Marlin mode, I was able to command motion in all axes from the display. Does this indicate my RS232 connection for the TFT is an issue? I still don’t see anything to indicate that the touch screen has been updated for “CNC Functions” and it does not have the V1 logo anywhere. When in Marlin mode, I do see the V1 splash screen at startup but I’m thinking that must come from the firmware on the SKR Pro, not the TFT right?

That is correct. Marlin mode just tells the TFT to emulate a 12864 RepRap Discount controller, and everything is firmware controlled then.

The fact that you are getting the V1 logo on that though means your firmware is probably correct, check the config.ini file for the LCD that the baud rate is set to 250000.

For Repetier, check that you do not have Repetier Server installed. It blocks access to the USB COM port by grabbing it first and locking it. Check your device manager for the correct COM port.

1 Like

Something is wrong then. It has progress bars when it is flashing the screen.

I don’t have a mac, but that doesn’t sound right. In Linux, it shows up as /dev/ttyACM0. I thought mac had a longer name. 250k should be right.

The console log will print a bunch of capabilities and the version number when it is connected for real.

I usually look at the kernel log while plugging it in (dmesg). It prints where it puts the tty.

Based on all of this, you have the skr firmware flashed and not the screen (although it will still have 3D printer logos). You haven’t connected from a computer yet.

I think this is only a problem in windows. But I may be wrong.

Thank you for the replies. Here’s an incremental update – searching eventually lead me to another thread where I found that you had to modify the baud rate in the TFT settings as well (similar to Repetier). Maybe that would have happened automatically if I had successfully flashed the TFT but I got that done and the “Printer Not Connected” error went away and I was able to test motion and homing from the touch interface. Still no luck from the software but for now I don’t need it since the screen is working. That “/dev/ttyACM0” is familiar from the 3D printer world connecting to the USB port of the SKR, I don’t see that in Repetier but I’ll keep trying.

As far as flashing the screen, that was really helpful to understand the expected behavior. Even though i was getting a “card inserted” message, the connector on the TFT felt a little crooked. Between removing and replacing the SD card and wiggling around, I tried again and was able to successfully flash it so I think I was just getting a bad connection.

Once done, that was quite a difference! I saw several errors or warnings during the flashing process but overall that was successful. I wasn’t able to note them all but one minor error I saw as missing file “[something]_usb.bmp” and then there were a bunch of red “invalid keyword” (I think) messages during the next segment but overall it seems successful

Now that I have basic functionality verified, I’m going to finalize wiring and then will come back to the control…now to find some good cable chain solutions for a Primo!

Thanks again for the replies.