LR2 z axis not homing

Anyone else have z axis homing problems with skr pro1.2 ? Just finished a lowrider 2 build and x and y will both home to the negative side until they hit the end stops but when I try to home the z axis it moves up instead of down… moving the z axis manually it works normal up is up and down is down… any suggestions?

For the LowRider firmware, homing to the top of Z travel is normal behaviour. Z1 motor works on ZMax (E2) endstop and Z2 motor.on XMax (E0) endstop.

ZMin endstop gets connected to the Z touch plate for probing to the bottom.

The trouble is that homing downwards with a single point (the tool tip) can’t give motor leveling data, which is the major point of the dual Z end stops. But at the top point each motor can have a reference that is a known height from the table top.

I see thank you for the info… I built mine with a higher than normal height capacity and expected to be able to level the z axis moving down with the end stops. Homing the z axis upward causes it to produce an error before it reaches the desired height. I guess there is no way around this to get it to home downwards and level both z steppers using the end stops? Is there a way to increase the amount it will rise when homing upwards befor producing the error?

The issue is making sure that the end stops are at a reasonable.end of travel.

My LR3 has a taller than normal Z height as well. I extended my Z axis by 50mm, but also changed things to be sure that it knows and can use it. My LR2 used to be able to go to about 225mm max Z and it was OK, but did require changes to the firmware.

If you are getting an error then you need to determine what is causing it, or else that extra height isn’t doing you any good in any case. You may require a recompile. The default V1 firmware is good to 200mm, and I think that you are going to run into stability issues if you go past this much, but a change to the max Z in the configuration.h file should allow you to home higher. It worked LR2.

Or, you might be able to just jog the Z axis up so that it is within the range of the switches and home from there. The V1 firmware does not require that the Z be homed in order to move.

You could change the home direction and recompile the firmware. In this case I would probably also enable the Z_Safe_Homing feature (where it must home X and Y first and choose a specific X and Y location to home Z) and home the Z over a hole in the table or spoilboard. This makes that spot less useful for milling but makes sure you don’t crash the tool into the spoilboard. You are at risk to possibly ruin an endmill or some materials if you leave it covering that location when homing, or if you accidentally home the machine again after clamping down your work. Personally, I think it’s a bad idea.

We home the LR up because there isn’t always room to move the machine all the way down (if you have a bit sticking out the end). We square going up (which is a G28 Z home command). But that only makes sure the two Z motors are at the same height. Then we probe down to the touch plate (or manually set the Z=0 with G92). That sets the zero. It doesn’t matter what the value of Z is after homing up (the default is 200mm, which is wrong for everyone). What matters is the top of your work piece, which will change for each job.

1 Like