LR2 New Build - TMC Connection Error


I’ve got a new Low Rider 2 (no endstops) build going, and I cannot get anything moving. I’ve got an SKR-PRO-V1.2 which I built according to instructions (I think… pictures attached) and it’s flashed with the V1CNC_SkrPro_2209 (v2.0.7.2/510). I’ve got Repetier Host running on my computer and it shows that it is connected.

Nothing is moving in Repetier, nor the touch screen. I’ve got a TMC Connection Error on the touch screen. I’ve tried reflashing the board just in case, and I triple-checked my wiring and printer setting in Repetier. Can you guys help me troubleshoot what I am missing? (I hope it’s not something embarrassing easy, … wait… yes I do… ha!)

Simple fix. You also need the power supply wired in.

Missing the 5 pin black touch screen plug set:

Yes i actually noticed this too and fixed it just prior to publishing this post. Thanks.

Hey. It’s hard to see in my picture, but I have the power supply wired into the stepper posts with jumpers to the power posts. Is this correct?

The tmc connection error means that:

  1. Your screen is talking to the skr
  2. The skr can’t talk to the tmc 2209s.

Can you send M115 and see what version the firmware is? It should be something like v510D. If you haven’t flashed the skr, then you need to.

Check that the 12V power is really reaching the drivers with a multimeter (careful, don’t short anything).

You can send M122 from repetier host to get even more info. For example, is it all the drivers that are not talking? Or just one?

Thanks for your advice… here’s what I got.

M115 =
19:43:08.138 : FIRMWARE_NAME:Marlin 510S (Mar 4 2021 04:38:08) SOURCE_CODE_URL: PROTOCOL_VERSION:1.0 MACHINE_TYPE:V1CNC 510S EXTRUDER_COUNT:1 UUID:cede2a2f-41a2-4748-9b12-c55c62f367ff

Picked a fine time to lend my tester out to a buddy… I’ll have to get back to you on that one.

19:49:33.933 : axis:pwm_scale/curr_scale/mech_load|flags|warncount
19:49:33.933 : X Y Z E
19:49:33.933 : Address 0 0 0 0
19:49:34.092 : Enabled false false false false
19:49:34.094 : Set current 900 900 900 800
19:49:34.172 : RMS current 1602 1602 1602 1436
19:49:34.252 : MAX current 2259 2259 2259 2025
19:49:34.264 : Run current 28/31 28/31 28/31 25/31
19:49:34.264 : Hold current 22/31 22/31 22/31 20/31
19:49:34.332 : CS actual 0/31 0/31 0/31 0/31
19:49:34.333 : PWM scale
19:49:34.412 : vsense 0=.325 0=.325 0=.325 0=.325
19:49:34.492 : stealthChop false false false false
19:49:34.572 : msteps 256 256 256 256
19:49:34.652 : tstep 0 0 0 0
19:49:34.731 : PWM thresh.
19:49:34.733 : [mm/s]
19:49:34.812 : OT prewarn false false false false
19:49:34.813 : triggered
19:49:34.814 : OTP false false false false
19:49:34.892 : pwm scale sum 0 0 0 0
19:49:34.972 : pwm scale auto 0 0 0 0
19:49:35.052 : pwm offset auto 0 0 0 0
19:49:35.137 : pwm grad auto 0 0 0 0
19:49:35.212 : off time 0 0 0 0
19:49:35.292 : blank time 16 16 16 16
19:49:35.293 : hysteresis
19:49:35.372 : -end -3 -3 -3 -3
19:49:35.452 : -start 1 1 1 1
19:49:35.453 : Stallguard thrs 0 0 0 0
19:49:35.532 : uStep count 0 0 0 0
19:49:35.534 : DRVSTATUS X Y Z E
19:49:35.612 : sg_result 0 0 0 0
19:49:35.692 : stst * * * *
19:49:35.771 : olb
19:49:35.851 : ola
19:49:35.931 : s2gb
19:49:36.011 : s2ga
19:49:36.091 : otpw
19:49:36.171 : ot
19:49:36.251 : 157C
19:49:36.331 : 150C
19:49:36.411 : 143C
19:49:36.491 : 120C
19:49:36.493 : s2vsa
19:49:36.493 : s2vsb
19:49:36.493 : Driver registers:
19:49:36.513 : X 0x00:00:00:00 Bad response!
19:49:36.533 : Y 0x00:00:00:00 Bad response!
19:49:36.554 : Z 0x00:00:00:00 Bad response!
19:49:36.573 : E 0x00:00:00:00 Bad response!
19:49:36.594 : Testing X connection… Error: All LOW
19:49:36.614 : Testing Y connection… Error: All LOW
19:49:36.633 : Testing Z connection… Error: All LOW
19:49:36.653 : Testing E connection… Error: All LOW

They really should start with that. None of the rest means anything if these are all low. It just means it can’t talk to any of the drivers.

Unless the jumpers are in the wrong spot, I suspect either the power supply isn’t working, it isn’t wired correctly, or there is a blown fuse.

510S means it is the series firmware and it is from V1. So that should be good.

My blue 15 amp fuse was blown! arrgghh

When I replaced it, the board no longer turned on. I must have something wired backwards. I guess I will try to get my tester back and test the polarity of my incoming 12V power source.


Alright, I tested the polarity, and I had it wired correctly… Any idea what to test next?

Guys, I’m at a loss. I put everything together on my board and it looks just like the picture in the instructions (except the the picture has 6 driver chips and mine came with 5). I replaced the blown fuse (15amp) and now the board does not power on, but does kick on if I remove the fuse again. I checked the polarity with a tester and it is wired correctly. The voltage from the power supply was 12.6 volts. Any suggestions would be deeply appreciated.

Can you check all the jumpers?


Thanks again for your help. Attached is all the jumpers circled. I double checked, and there are no jumpers underneath the driver chips. There are only 5 driver chips (hope this is correct that’s all that came with the kit). I also double checked that the sensor less pins have been bent out of the way. I confirmed with a tester that the polarity coming from the power supply is correct, and it is at 12.9v.

It is currently wired with 12v coming in to the board. The minute I put the jumper wires from the power inputs to the motor power inputs, everything turns off. The tester shows no incoming power when that happens.

1 Like

What if you take out the drivers? Maybe one of them is shorting?

Try disconnecting the motors and the screen too. Then if it turns on, then try one thing at a time until you know what is shorting.

I have removed the drivers, motors, and screen connection. (See attached) It is not kicking on.

Bummer. And it comes on when you take out one of the fuses, or when you disconnect the motor power? Can you share a photo of the bottom?

@vicious1, do you have any other ideas?

Yes. It comes on if the power to the motors are interrupted. I’ll attach a picture of the bottom.

1 Like

Well shoot. Looking at the schematic I think the 15A goes straight to the cap on the power pin on the driver sockets. I can’t think of anything that could cause issues with the drivers out, it must be the first bad SKR we have had.

That sucks sorry Carden.

PM or email me your order number and we can get you situated ASAP.


When I get home, I’ll start sending you the needed information. Thanks everyone for helping troubleshoot.


I don’t see any shorts or missing solder. Bummer.