LowRider3 Homing Problem

Hi, I’m having an issue with homing on my LR3 dual endstops.

Firmware: v513 - V1CNC_SkrPro_DualLR_2209-

When y and z homing, It seems one stepper motor continues to run for a while after contacting the end stop.
I have verified that no current flows when the limit switch is pressed and current flows when the limit switch is depressed.

When the Z-axis touches the endstop, the E0 and E2 LEDs on the control board turn on, and when the Y-axis touches the endstop, the Y, E1 LEDs turn on.

The M119 code execution result does not seem to have any problems.

Y homing works fine sometimes.

It’s hard to explain my problem in words, so I uploaded a video to Google Drive, but I don’t know what to do as links are prohibited on this forum.

Can anyone please tell me how to solve this problem?

You have to be active on the forum for a short period of time before you are allowed to post links. A workaround is to modify your link slightly in a obvious way so that the forum software no longer recognizes it as a link. We can edit the text to reconstruct the link to see your video.

Y homing works fine sometimes.

If it works “sometimes” check to make sure you have the endstops plugged into the right connections. If you have them reversed, so that the endstop for Y is controlling motor Y2, and the endstop for E1 is controlling motor Y1, then strange things happen including working “sometimes.”

Edit: An intermittent wiring break and electronic noise have both been the cause of “sometimes” behavior wrt endstops. Seeing the video will help us make a more educated guess.

Thank you for your replay.
I checked all the wiring this morning and they are as pictured.

Below are links to videos of my problem. You will hear a loud noise, so turn the volume down to play. :joy:

I’m waiting for a new motherboard to change the motherboard and test it out.

Z-Home malfunction

Y-Home malfunction

I compared your wiring diagram to the documentation for endstops on a LowRider, and your wiring is correct.

The noise in your video is the stepper motors “slipping” or “losing steps.” This is non-destructive. This is an indication that, for whatever reason, the firmware is not sensing the opening of the switch. I’m assuming you wired your switches normally closed since M119 is not having a problem, and I’m assuming it will move the axes towards home when the homing command is given.

So, what happens if you start to home somewhat away from the home position and you press the switches manually? Does the stepper motor stop, or keep running? If it stops, then I’d look for some mechanical issue with the switches getting pressed.

I’ve seen two problems similar to yours come across the forum in the last couple of weeks (no mechanical issue). I don’t think we ever reached a definitive answer to the problem, but it appeared to be an issue with the pullup circuitry for the signal pins for the endstops. The suspicion was a manufacturing issue with some SKR Pro boards. One person solved his problem by replacing the board. The second person solved his problem by wiring 1.5K resistors between the signal pin and the VCC pin for each of the endstops. Here is that topic.


When I pressed “Home” and pressed the switched manually,
Y axes always stop. However, one side of the Z axis doesn’t stop and keeps going up.
I replaced the PSU with 12V and tested it, just in case, and there was no difference.
I plan to replace and try again when a new board arrives.
Thank you for your reply :slightly_smiling_face:

Before you buy a new board (or before you swap them. There are some things to check. There are some common issues that can cause this.

While it is grinding like that, send an M119 to see the state of the endstops. The wires may be loose and at the extends, or there may be a physical mis alignment that is keeping the switches from triggering.

FYI. The endstops don’t stop motion. They only stop the homing sequence.

Make sure the motors are wired next to the right endstop. If you have them backward, only one motor will stop.

Thank you for your advice.
I bought 2 more boards and tested them, and 1 seems to be working fine. But I still can’t shake the feeling that something isn’t working out.
I now have 3 struts. I’m going to try some more tests by changing the board after reassembly.

Is this still happening? Does the LED light turn on, but M119 mistakenly reports that the Z end stop has not triggered (even though the LED light is on). If you’re observing this exact behavior then there’s a couple of recent threads discussing cause (endstop LEDs are dividing/lowering voltage enough to confuse microcontroller from correctly detecting triggered endstop), and fix (either add 1.5k pull-up or snip LED).

Thank you for your advice. I tested with pull-up resistor(1.0K) today.
It works fine so far. But I still don’t know why that happens. I have 3 of SKR Pro boards and about 2.03V is detected on all the boards. One of them worked fine even without the resistor installed.
Testing done with a 1K resistor installed today detected around 2.6V.


Some info and context on cause at Lowrider V3 Endstops Do Not Trigger - #31 by sru_tx

Curious what gauge wire you’re using for the endstop wiring? Wondering whether builds with smaller gauge wiring and/or large gantry are more likely to encounter.

I installed and tested the pull-up resistor after reading the articles in the link you attached.
I used 22 AWG wire in all my tests.
What’s strange to me is that if the cause of this problem is floating, 2.03V is detected on all three boards, why is this particular board working fine?

Anyway, all issues are fixed now, I’ll do more testing as time permits.
Thank you for your information. Have a nice day :slightly_smiling_face: