Lowrider Homing Y+ Endstops not working

Hello there, I built the Lowrider CnC as shown by Teaching Tech with SKR 1.3 and Dual Endstop firmware and all just went fine.
I had a few issues with my X and Z Endstops but they’re working fine now.

I wanted to home the machine to the Bottom right, the motors are spinning in the right direktion but the endstops do nothing when hit.

I tested some things in the firmware by myself with no success.
I tested the endstops with M119 command:
y_max: TRIGGERED when pressed.

I read a post of a Guy in this forum but can’t post the link here so if you want to see that post seach for “Teaching Tech SKR 1.3”

and tested the files from a Guy more down in this topic and they’re working as they’re supposed to… but then my X axis homes to the wrong direction.

Please help me…
Greetings from Germany and sorry for my bad english :stuck_out_tongue:

Bottom right would be +X and -Y? Which axis do you have with two motors? It’s easier to flip the one with only one.

X has only one motor.

And sorry yes, X+, Y-.

So you should be able to change the X_HOME_DIR to +1, set the bed size, and put that right endstop in the xmax port. Check with M119 and then test with G28 X.

The problem is that the file of the one guy is allready a .bin and i cant edit it. or is there any way to do that ?

Not that I know of. Some settings can be changed with gcode, but not homing direction.

You can use the source he made to make the bin, change the homing dir, and recompile. tt has a video on compiling marlin for the skr in platformio. Is there a particularly good reason for wanting it to home to the right?

Yes, changing the directions of X and Z and homing dir is working fine but i made many changes in config.h and config.adv for the Y homing but nothing is changing at all. Till now i flashed the Firmware nearly 100 times but the endstops are still not working. The changes i made had no effect. The endstops are even not working with the files and tutorial from Teaching Tech in Y- dir. The firmware i downloaded from the other topic are working for the Y abd Z axis but then the X direction is wrong and i dont have the source from him so i could compare them or anything…

Im building a table for the CNC witch is facing to a wall with the top.

Its pretty hard for me to translate all this and find a sulution for my problem, i understand the changes i made in the config but i cant figure out why this is not changing anything…

I’m sorry. I imagine it is difficult.

Some things only affect the default EEPROM state. So after flashing, you can send M502. That will delete everything “saved” in the EEPROM and restore any settings from the flashed code.

If you are worried that it isn’t actually flashing, you can change something simpler and see. I have changed the version string, which prints out with M115.

I’ve tested that and still not working… Is there any way I could get a sourcecode for the skr 1.3 where the Y endstops worl so i can compare it to mine ? or even use it ? is there a difference to the ramps board so i eventually could use this sourcecode or compare it ?

What isn’t working? I suggested two things.

Anttix had a version he posted that was working, but I haven’t seen one with the other hone direction.

I tried to delete the EEPROM and flash it with the new firmware.

Im sure that the SKR 1.3 took the new firmware because the compiled file is a .bin and changes after rebooting the SKR to a CURSOR file. I also changed other things for example X home dir witch worked right after rebooting the SKR.

Hi there. Have you had any success yet with this problem? Because I’m looking at the same thing. Trying to home bottom left though. But same thing with the y axis not stopping when hitting the micro switches.

Don’t worry. Figured it out.

Ok, my problem is still not solved… can you help me then when you have a sulution ?
What have you done ? can you send me your source code ? please! :smiley:

Hi there. Sorry for the late reply. The emails have been going to my junk mail. I’m away from home at the moment but I’m keen to help you out. I need my computer and will be home from the 2nd. I’ll get back to you then.

Hello, can you help me now pls ? hope you had great hollidays!

Hi there Woody.

Firstly let me please sincerely appologise for not getting back to you sooner with regards to your issue above. I honestly completely forgot that I had promised to help you out and I have not been on the forum for months. I haven’t even had the Lowrider set up all year either as (I’m sure you’ll agree) it’s been a challenging year all round and I haven’t had time to indulge in the project.

Please let me know if your still require my solution to this issue. I can’t remember what exactly I did, but I’ll be able to figure it out by looking through the Marlin FW that I got to work.

Again, I’m really sorry that I’m only just replying to you now after 5 months!!



Hi Woody,
just in case you are still stuck (I hope you’re not), I had a look through my Marlin FW and I had put a comment next to the line that I had changed that had fixed the Y axis homing issue that I had.

I think that your project required something slightly different as your were trying to home to the other end?

But hopefully, if you need it, you will see some help in the code below.

This is an extract from the Config_adv.h file under the Dual Stepper drivers section.



#define INVERT_Y2_VS_Y_DIR true // Set ‘true’ if Y motors should rotate in opposite directions



#define Y2_USE_ENDSTOP _YMAX_//changed this from YMIN and that fixed the Y homing issue of not stopping for the MIN switches.




Thank you for your suggestion, but i allready tested this and its not working… Can you eventually upload your firmware for me ? so I can compare it to mine ? that would be very nice!