Laser/Lightburn Help Please!

Ok brand new to lasers and I’m lost. I have the new Jackpot board hooked up and all seems well with that. The board config shows 0=0% 255=100% on the laser. I was trying to do a focus test in lightburn. With the laser turned all the way up to 99.99 it wont even put a mark on a piece of paper. But if I hit the test button it will sure enough burn though the paper and leave a mark on the MDF underneath. Is there a setting that I’m missing???

This is the setting I changed in Lightburn…

image

I also turned on enable laser fire button and laser on when framing and I have no idea where the laser fire button is and it does not turn the laser on for framing. I’ve watched a few videos and will continue to search more. Just hoping someone here will know right off and be able to lead me in the right direction LOL.

I’ve also tried saving the Gcode from LB and loading it onto the SD card. Still the same extremely low output.

Disregard. I’m an idiot per usual. I hooked up power and ground from the 12v power supply and a single wire from GPIO 27 to the NEJE board. Turns out I was supposed to hook up a ground from the board as well and put it on the same ground pin from the power supply. Fixed that and all is well!

2 Likes

@Jonathjon how do you have your NEJE laser wired up? I have the NEJE E40 with a FluidNC board.

Using the NEJE board that came with the laser module, I have a 3-pin cable connecting the FluidNC board to the NEJE board using Vin-TTL-S pins. Then I used the 4-pin cable between the the NEJE board and the module.

When I run a burn sequence from Lightburn, it doesn’t burn much at all, but when I press the test button on the NEJE board it burns much stronger. I think I am missing the same step you did.

Can you elaborate on your wiring setup for your NEJE module?

I have the wires coming from the laser to the board that came with the laser. The one without the small screen. Those both plug into the board. Then on the opposite side of that board on the screw terminals I have power and ground coming from a separate 12v power supply. Then GPIO and ground coming from the jackpot to the ground and ttl screw terminals. I’m sorry I can’t remember the gpio number and I’m not home to look at it. My mistake was only running the gpio wire to ttl and not also running the ground wire. You should end up with 2 wires on the ground terminal. That fixed it for me. Before that I couldn’t put a mark on a piece of paper at 100%

I think I have it as you do now. Can you confirm? I have TTL and GND from the MKS DLC32 board and then I have a separate power supply connected to the + terminal and sharing the GND with the board. I then have the 4 pin cable going to the module.

Another thing that confuses me is the extra 2pin header on the module. What is that for?

I think I need to use a heavier gauge wire for the power input. I am choking down the amperage with a thin DuPont wire I believe.

That looks like how I have mine wired. I did use 18 gauge from the power supply to the board though. Is it working better now?

It did seem to burn much stronger after adding in the GND that you mentioned. So I believe that was the answer. Next time I get the chance I will upgrade the power input to a higher gauge wire and see if that increases the laser output even more. I was able to burn stronger but still not able to cut through thin wood in a few passes.

1 Like