I'm a bit of an idiot, how do I load the software onto the control board?

I got the FluidNC Pen/Laser CNC Controller TMC2209 from Bard Dring a couple months ago. I have most of what I need to put together my table, and I had a V1 that I am upgrading to a V2.

But all of that said, I’m sorta an idiot about the control board and software. Can someone post a link to some really dumbed down, bullet proof instructions on how to get a functioning table?

I’m supposed to have this thing working by the end of the week!

I don’t think we have anything bullet proof. You can flash the esp32 with the fluidnc web installer. The trick is getting the right config.yaml. i have an older pen board, so mine won’t work for you.

Well then, let’s get after it!

The best starting point would be to connect your Pen/Laser board to the web installer as Jeff mentioned above.

Connect the USB cable to your power on your board, connect the USB cable from the board to your computer.

Then open up the Chrome browser (must be chorome!) and point it to the web installer:


If you can get that far, then you’ll be able to see the board as a wireless access point and we can then connect over WiFi and help you sort out a config.yaml.


Really appreciate the help.
I’ve got the board connected, Chrome open, web installer up. But it really doesn’t want to install any of the firmware options; keeps telling me that it has failed to connect with the device, or that the device isn’t in boot mode.

Thoughts on next steps?

What kind of host do you use (Windows, Mac, or Linux?)

Next step is to use the FluidNC native installers, or if even those fail then to look at the behavior with FluidTerm.

We also need to have you report what the LEDs on your ESP32s are doing when trying to load. There’s a chance that the ESP32 isn’t correctly being put into the firmware loading configuration.

The LED; I have a bright red led that appears to be power. There are no other LEDs lighting or blinking at any point during the process.

Then the process isn’t working correctly.

Pull the ESP-32 off the board. Plug in USB to the ESP-32.
Hold both the BOOT and EN, start the flash utility, then release EN and wait a bit.

Tell us what happens.

No change.

This is where I got the board:
tindie product 33366583

in case that helps.

No LEDs blink, only one LED on, no flash?
Are you able to get FluidTerm to connect?
If so, then try pushing the Boot and EN buttons. You sould be able to get the ESP32 to reset, then get debug text in FluidTerm. If not, then you’ve got ESP-32 or Windows issues entering into this.

Do you have an alternate machine to test with?
Also- are you sure you have a full USB cable and not a charge-only cable?

You might need to install drivers to get it to connect.

It should then show up as a COM port

1 Like

Depending on which specific ESP-32 Dev board is in use, it could have a CP-210X or a CH340.
Drivers are different between them.

That’s why I’ve asked about whether FluidTerm can connect.
It’s also why I suggested a picture would help troubleshoot.

Well, I think I mentioned I was an idiot.

I didn’t have a micro usb cable handy to connect to the board with. Borrowed one, might be power only. I"m going to go find a new one.

I tried to recreate the steps I had been doing, but with the board disconnected, and it acted exactly the same, which makes me think it might be a cord problem.

OK, I’m going to have to step out to go find a cable which I KNOW is good for data.

I don’t know what it means when you ask about whether FluidTerm can connect. The web installer will say ‘the controller does not seem to have FluidNC installed, do you wish to install it?’ even when there is NO controller connected to it at all.

Which is so very not helpful.

Picture of current state.

I’m going to plan on heading to the store and home and then checking back in here, after I know I have a good cord. And thanks again for the help. I’ll hope to hear more or report back if I figure anything out.

We want to start FluidTerm and see what it reports when you are connected to the ESP-32.
FluidTerm is a utility you’ll find in the offline set of products, and provides a terminal window to the ESP-32’s debug UART. There are also offline (Local) installers that run, and these also provide you with a terminal window view of what is happening with the ESP-32 as you try to flash it.

That’s how we get debug information on how next to advise you.

OK, got a known good cable. It has not changed anything about the process. No extra LEDs, nothing.

I am getting this code when it is failing to do anything:

esptool.js Serial port

What can I try next?

You’re running fluidterm.bat from the source distribution and getting that?
Post a screenshot.

OK, some step by steps:

Select the only option, hit Connect

Hit install:

Hit big blue button:

I’ve tried different options here. Not sure I care which; this time, wifi

I’ve tried a few different of these options, too; this time, firmware update:

Hold down the Boot button on the board:

Thanks for getting back to me on this! I know I’m tired, you prob are too, but I really appreciate any help!

First, we need to know if your serial port is enumerating.
Open device manager in windows.
Make sure the USB cable is not plugged in. Make note of what COM ports you have.
Now plug in the USB cable. USB enumeration should happen and you should get a new COM port.
If that doesn’t happen, then you need to get the correct windows COM drivers for your ESP-32, as mentioned above.

If the COM port does appear, then we need to open FluidTerm and find out why it isn’t working.

Download the FluidNC local installer. Latest release is 3.7.17. The windows release is here:

Unzip that, and run the fluidterm.bat file from the distribution. (USB cable needs to be plugged in, COM port must be present in device manager).

From there, alternately hit the EN and Boot buttons on your ESP32 and tell us what happens in the FluidTerm terminal window as you do that.
Edit: paste screenshots or cut/paste the terminal output.

I did not get a new COM port when I plugged in the cord. So, I need the drivers.

THoughts on which of these would be my best bet?