How to tool change with Fusion CAM and Marlin


I’m pretty new to this and will finish building my MPCNC within the next 4 weeks or so. I already printed the Crown test and it worked great(without squaring or fixing the CNC to anything, just for fun :-)). Later, I want to use something like Repetier to control the CNC, but I have also connected a LCD with encoder to the Ramps Board.

I modeled something in Fusion 360 and I really want to use its CAM to generate G-Code. In my current setup I will have to do at least two tool changes. I used this post processor ( to generate the G-Code, but it uses only one tool for everything. How can I add in something like an automatic pause, and then carry on when hitting ‘ok’ or ‘start’ on the screen. I’m sure I am not the first one having this problem but I couldn’t find a good answer on how to solve this problem.

I hope you can help me out.

Thanks, Max

CAM> Setup > Manual NC >Force Tool Change

Hopefully your post processor is set up to handle the tool change properly, but you’ll want to verify it in the gcode. I’ve been using the one guffy posted, and works ok.

1 Like

You might want to try the post processor linked at the bottom of the milling basics page. If I am not mistaken Guffy has made it full featured.

It’s not the elegant solution you’re looking for, but you can post out individual or multiple operations by highlighting them in the setup and hitting post process. You can also set repetier host to keep the steppers energized upon job completion so hopefully you don’t move anything while changing tools.

Thanks for your help. Unfortunately I didn’t know how to include the .js file provided by Guffy with the .cps file. Fusion always throws an error, telling me that the .js file could not be included. I already copied it next to the .cps file to Macintosh HD⁩ ▸ ⁨Benutzer⁩ ▸ MyUsername ▸ ⁨Autodesk⁩ ▸ ⁨Fusion 360 CAM⁩ ▸ ⁨Posts⁩ but still the same issue. Then I just copied the code from the .js file into the .cps file at the line where the include was. Now it works and generates Gcode, but still no sign of a tool change in the code, even if I do the ‘Force tool change’. Do you have any further ideas to get this working? Attatched are my test GCode and the .cps file I’m using right now. (1.6 MB)

I found my mistake. All tools were labeled as Tool #1 in Fusion, so for the PP they must have been all the same.



Hi Maximilian, I tried your zip copy above in my Fusion 360 but get this new error, any idea how to solve it?


[attachment file=119752]

before your file the error was:

[attachment file=119753]

Hi Maximilian. I am experiencing the same issue. But I wonder if is just the matter of changing T1 for T2, or what else needs to be included in the gcode, so that the attributes of the new tool are taken into account. Any hint, will be much appreciated.


Made that mistake few times. I like to export the setup sheet so I can see how many tools changes and for my complex stuff have with it me when I run it. If you simulate it will also tell you the number of tools changes. Also if you enable cloud library’s when you add the tool you can set it to be a manual tool change so in every project it will default to being a manual tool change.

Of course this will all change once @vicious1 releases that top secret automatic tool changer upgrade.