Help again!

hey yall I’m needing help here, so about 5yrs ago I built the V1 version and it has worked great! couple of months ago I noticed that the left hand side would fall really bad/fast when I shut the power off then it kept getting worse until it now falls even with the power on so I figured the motor went bad so i replace the motor the other day and it is still the same. I bought all the steppers from here and the Marlen board also. can some one tell me what is going on? thanks!!

1 Like

A first gen LowRider. Nice.

First thing you’re going to need to do is provide some more details. Which board did you buy? 5 years ago is a long time.

Pictures of your controller board would help, and in particular identifying what stepper drivers are in use on that board.

1 Like

Had time to grab some pictures before work this morning so I’ll shoot them over!

Ok this is the new stepper, notice the wire colors

Old stepper that is working great, yellow wire, blue wire, green and red
Uploading: IMG_20240513_080112658_HDR.jpg…
Processing: IMG_20240513_080219382.jpg…
Uploading: IMG_20240513_080243500.jpg…
Board: black wire, red, green, blue

This is just the overall build
Does any of that help?

1 Like

Doesn’t look like the picture of the board came through, I’ll resend

Black wire, red, green, blue

I’m still fairly new to the Lowrider, but dropping on motor-off is pretty normal, usually signs of really good alignment. If it’s falling when motors are engaged, that’s a problem for sure, maybe the collar grub screw is loose or like you said a motor issue.

For preventing the healthy drop, I added anti-backlash nuts to my lead screws. No more dropping, so far I’ve not had any issues with Z performance or accuracy.

Motors don’t really break. Their wires do sometimes.

That is a Rambo board. They are pretty tough.

The low rider should fall when unpowered. If it doesn’t, your screws need some lubrication. Sometimes gcode can turn off the motors. Or the gcode sender can. If the motors are holding and being over powered, it sounds like crunching gears (it isn’t, but it sounds like that).

After 5 years I would definitely be suspect of the grub screws holding the coupler that connects the motor to the lead screw. The brass leadscrew nuts are also meant to wear out faster than the leadscrew. Those might need replacing. If those mechanical parts are fine, and the motors are dropping then they are engaged, then it is a problem in the wiring. Not a wire order, but a problem with the wire coming disconnected occasionally. But definitely check the other stuff first.


Ok thanks! I’ll check into that, it’s a consistent problem. By that I mean that it happens every time I try to use it. If I level it up and down and then cycle the power it always drops maybe a half inch and I have noticed the screw turn when it drops (just some added details)

Hey could you send a link to those please sir

If it only drops when you power cycle, it sounds like it’s a healthy drop as expected. Nothing wrong with motors, it’s doing what a well aligned machine should.

As for the anti-backlash nuts, I wont link you anything exact cause these are specific to the size and pitch of your leadscrews, but they look something like this and are common to find in other CNC/3DP projects/machines.

The anti backlash nuts add friction. There shouldn’t be any backlash because the weight of the gantry keeps things down at the bottom of the backlash.

It shouldn’t drop when the motors are engaged and if the motors disengage, you’ll have registration problems anyway.

How are you sending the gcode? Using the screen?

Yes they drop when I shut the power off and then I level it up , then I hold up on the side that always drops while I power it back up, hold it about 20 seconds to give it time to power up and then release it and it drops. . .
I start out using Estalcam and then send it to Repeterhost and save to a SD card and “print” from that screen then. . . Is that what you’re asking Jeff?

Yes. The screen doesn’t disable the motors automatically on pause/cancel. If the gcode has an M84 or M18, then it is disabling the motors.

The motors won’t engage until you send a move. They will also automatically disengage after 5-20min (depending on the version of firmware).

What I did was:

  • Put a block of the same height under each end of the LRv1.
  • Twist each leadscrew 1/4 turn to lift it off of the block and let it settle back down to get a good even contact on both ends.
  • Power it up and the first move was a jog in +Z to lift off of the blocks, and I would remove the blocks.

That let me get a level start and I wouldn’t let the motors disable until I was finished with the job. I also had blocks for the dual Y so they would be square to the X at start. After they are engaged, they move in lock step.

Newer firmware enabled dual Z endstops at the top of travel. New LRs will sit flat and after turning them on, you can home up and each end will go up until it reaches its own endstop switch. That will make it automatically square from then on. I still use the blocks :slight_smile:

Ok I’m back, so I’m pretty sure that using blocks works for my previous problem but i can’t rightfully try it because I’m having problems now with estlcam and repetier host. So I got a new computer and thought i set bot of them up like my old computer but when i do a project in estlcam it pops up and says something like 29 minutes of cut time then when I send it to repetier it goes somewhere around the 30 hour range and ive had it go as high as 308 hours (not really willing to wait that long)! so I’ll send some screen shots and y’all let me know what you think

1 Like

Your “feedrate units” for “CNC controller” is set to mm/sec and it should be mm/min.

You can open the gcode in a text editor and look at the commands. F is feedrate and it will be interpreted as mm/min. So if you see something like F10, that will end up 10mm/ min, which will take forever.