GRBL, Octoprint, and a whole lot of headache

Hi everyone,

Running my ZXY using a Makerbase MKS DLC using grbl. I have it connected to a Pi and using octoprint with better grbl support. It was working amazing…but after an octoprint update it no longer works.

It will home the Y but then I get an Alarm 6: Homing fail. Reset during active homing cycle. I can $HY and $HX individually just fine, jog the machine, but as soon as I hit start on a code It will home Y then I get the alarm. Octoprint just tells me to check limits. which I have and even replaced.

I’m convinced the problem is Octoprint because when I have it plugged in to my laptop using UGS the same code works just fine, every time.

There is some starting and cancel gcode in octoprint settings. Maybe start looking there.

I checked there too, cleared that all out.

Changing monitoring state from “Operational” to “Starting”
Send: ?
Changing monitoring state from “Starting” to “Printing”
Recv: <Idle|MPos:-522.000,-632.000,0.000|FS:0,0|Pn:Z>
Recv: ok
Send: $HY
Send: G92 X0 Y0
Changing monitoring state from “Printing” to “Cancelling”
Send: G4 P0.01
Recv: ok
Recv: ok
Send: \x18
Send: G Changing monitoring state from "Cancelling" to "Operational" Recv: ok Recv: Recv: Grbl 1.1h ['’ for help]
Recv: [MSG:Check Limits]
Recv: [MSG:’$H’|’$X’ to unlock]
Send: ?
Recv: <Alarm|MPos:-522.000,-682.000,0.000|FS:0,0|Pn:Z|WCO:11.600,5.160,0.000

It sends $HY and G92 at the same time and then changes the state to cancelling. My guess is octoprint is doing something with the $HY, but I don’t know what. Can you send those one at a time and make sure it is complaining about the $HY?

If that is it, I would try asking in an octoprint forum/discord. It may be some new functionality that was added that didn’t think about grbl.

1 Like

I disabled every plugin except better grbl support and have gotten it to work for the moment. I’ll report back. Thanks for your help!

Id be curious to find out what is causing that.