FluidNC v3.7.15 SD card issue?

I just tried to execute/run a job I uploaded to the SD card on the Jackpot board. The SCcard is 32GB and formatted as Fat32, FluidNC is v3.7.15. I get the following error:
[MSG:WARN: Low memory: 14020 bytes]
[MSG:WARN: Low memory: 13140 bytes]
Error : undefined :undefined

What does this mean? The SD card is 0% full (Total: 29.71 GB | Used: 384.00 KB).
I’ve run jobs in the past with no issues - this file is the largest yet at 153.71 KB. Is there a file size limit?
The Jackpot board is white, I can’t seem to see any version number on it. If there should be one, where might it be and I’ll have to take it out of the case to look.

It means RAM memory, not SDCard. Do you have multiple devices connected? You can also disable SSDP to save memory

1 Like

That typically means you refreshed the browser too often or have multiple devices connected (with the V2 gui) to get the low memory. Error 66 is bad file read.

I would suggest taking the card out transferring the file directly to it and rebooting the Jackpot.

Can’t tell which of the two errors caused the other one.

If you did this via wifi, you got a bad transfer. I highly suggest you do this directly. Until the V3 GUI is finalized and then see if he wifi transfers are more stable.

Ok. I pulled the SD card, reformatted it with fat32. Copied the .gcode file from my laptop to the card. Put the card back into the Jackpot - re-applied power. Homed/set up my starting point on the CNC, pressed play and:
[MSG:WARN: Low memory: 13304 bytes]
[MSG:WARN: Low memory: 13184 bytes]
[MSG:WARN: Low memory: 11552 bytes]
[MSG:WARN: Low memory: 11368 bytes]
Error : undefined :undefined
[MSG:WARN: Low memory: 9980 bytes]

What did you mean by ‘multiple devices connected’? I have only my laptop connected via wifi (a dedicated wifi router just for the jackpot). What’s the next test? :slight_smile:

Never seen that happen when loading a file.

Let’s see the first section of the file.

Just make sure nothing else is connecting. Some people connect with a laptop or tablet, then a phone at some point or any pother device. By default windows like to “connect by default” So those other devices can log in and use memory. V3 does not let this happen (It is coming soon). Seems like this is not the case here.

Are you using stock settings or did you switch to STA mode?

You have updated, did it work with other files you have used before? Are you using V2 or V3?

If the file looks good (waiting to see it), I would suggest falling back to 3.7.12.

  1. I did switch it to STA mode (that’s were it connects to your home wifi, correct. If so, that is the mode it is in). The jackpot is the only wifi device on that wifi. My home wifi is using a different router and different subnet all together.

  2. When you say ‘V2 or V3’, what are you referring to? The WebUI or something else?

  3. first section of the file:

(Project FluidDialPendantF+B)
(Created by Estlcam version 12 build 12.065)
(Machining time about 01:25:03 hours)

(Required tools:)
(1/4" Upcut)
M0 (MSG CHANGE BIT TO: 1/4" Upcut RPM=20000)
G00 Z10.0000

(No. 1 Pocketing parallel: Pocket 3)
G00 X120.5171 Y358.1818
G00 Z0.5000
G01 Z-6.0000 F1014 S20000
G01 X119.2109 Y358.7846 F2034
G02 X118.3199 Y360.1776 I1.5074 J1.9456
G02 X118.5719 Y361.5489 I1.7130 J0.3940
G02 X121.8516 Y358.9764 I1.6441 J-1.2808
G02 X121.3712 Y358.5334 I-1.6355 J1.2918
G01 X120.5171 Y358.1818
G01 X119.4118 Y355.8707

I disabled the SSDP and I’m still getting that error. The only device that was connected in the past was my laptop and a tablet. I’ve since, turned off the tablet and am only using the laptop to troubleshoot this issue I’m having. Thanks.

Your router/network could be blasting your connection. The only way to know for sure is go back to AP mode to see if it does not have the issue.

Looks okay, do you have another file that you have previously proven that you can test with?

Yes the webUI

In the V1 settings github, you will see under each machine there is now a folder. If you want to try V3 wipe/erase the ESP32, use 3.7.15 and the V3 files.

Here’s one that worked (in STA mode, on the dedicated wifi/subnet):

(Project Brillon_aniv_top)
(Created by Estlcam version 12 build 12.045)
(Machining time about 00:25:09 hours)

(Required tools:)
(1/8"  BADGER)
(1/16" Downcut)
G00 Z10.0000

(No. 1 Pocketing linear: Multiple)
G00 X264.8382 Y136.0659
G00 Z0.5000
G01 Z0.0000 F2032 S19000
G01 Z-2.5000
G01 X14.5822 F3302
G01 Y133.8749
G01 X264.8382

Oh, and I’m using the V2 WebUI (I think. Not 100% sure how to tell - it is NOT V3, that I know for sure)

Ok. Got it now (too many ‘V’ and number references :joy:), I am on V2 of the WebUI.

Does it still work? If it does something is wrong with your new file.

Yes, it did. Hmm. I’ll have to go look as to why. Maybe because of a different version of Estlcam 12, but I’ll look into that. Thanks for the help and trying. This is going to be a big bummer if I can’t figure this out.

Most of us use EstlcamV12 It works fine.

Compare the first section of each file and we can figure out what is wrong. All I can see is you have no feed rates whatsoever, so you missed a few setup steps for sure. Are you in GRBl mode? Figure out why no feed rates are showing, you should have at least one, if not one on each line.

If you are trying to upload the file over WiFi then it’s most likely the file is too big. I get that sometimes. I can’t remember off the top of my head what size it stops working but there are several I can’t upload that way, I just bring the sd card into the computer and load it there

1 Like

After all of the above suggested steps, and having the feedrate included in the gcode file, I’ve found my problem. It was me :rofl:
The file name I was using had a ‘+’ character in it. FluidNC does NOT like that. Removed the ‘+’ and the file ran with no memory issues.
Wanted to follow up if others forget that there are certain characters in the file name that should NOT be used :wink:

1 Like

Good catch, need to remember to ask that the next time.

you may want to log that as an issue on Fluidnc, there may be something they can do to fix that sometime.