FluidNC not advancing past loading on Samsung tablet

Good day,

First of all, thank you for all your wisdom.
This is my first post since I have a problem I could not yet find the answer to.
I have been secretly rooming this website to have my MPCNC running for the better part of 7 years.
So, this gives credit to the tremendous amount of information on your platform.
I do salute you.
Having a mechanical background, the software and firmware side are rather weak on my end.

Recently I have updated my MPCNC Burly with a Jackpot board, coming from a RamBo board, boy what an improvement.
The main cause of destroying my projects in the past had to do with either a bad USB connections or laptop computers randomly seizing themselves.
This is a thing of the past now, while using the microSD card on the Jackpot itself.

I wanted to go fancy and have a dedicated Samsung tablet to navigate the FluidNC.
Therefor I digged-up and ancient but functioning Samsung GT-P3110 Tablet (from 2014), fully erased everything except for a browser. And have the device dedicated for the CNC.


It all looked promising.
Starting google chrome, going to the WebUI,, seeing the mainscreen opening. However it will never go past the Loading… phase.
The screen is not frozen, since I can only open the dropdown menu the adjust preferences, setup and credits (far right on the screen), the remainder of the tabs do not respond.

Foto samsung Tablet

I tried another browser but that did not even load the WebUI.
Any suggestions to get this tablet to work?
Or should I just accept that this tablet is a piece of the past?

Thank you for thinking along.

I can’t say definitively that it couldn’t work but I’m not at all surprised. That’s probably running Android 4.2 and I don’t think you’re going to find a browser to support it.

If I’m not mistaken, this address is only seen as part of Captive Portal log in.

I don’t know enough about Android to tell you the steps, but I would attempt to get that connection accepted as a connection that doesn’t use internet, and then try to connect directly using without the generate_204 portion.

Captive Portal has some limitations that makes the WebUI only partially functional, and I have seen it just not work like this sometimes as well.

This will be the hard part- when I tried an old google nexus, I couldn’t get it to accept that it had a valid internet connection.

Android wanted to test certain ports could connect out to the internet and if that didnt connect then wouldn’t let me use the FluidNC AP because it would not stay connected.

I’m sure there is a way to force Android to do that, but we’ll need to look it up.

The same page that allows you to update the jackpot/fluidnc now lets you easily adjust the internet settings.

IF…you have a good signal to your home wifi network at your machine you can turn on STA mode. That should help. If you run into any issues with that you can hook it back up and go back to AP mode.

If you’re up for more tinkering, you can always see if there is a custom firmware available for that tablet. I have an old Asus transformer tablet that I was able to put a newer android version on. Now depending on the specs and version of android, it will be considerably slower on boot, but if you are just running a browser, it’ll probably be OK. I forget where I got it from, but maybe start with XDAforums and that could point you in the right direction.


Try here Galaxy Tab 2 10.1" Android Development | XDA Forums

Reading through the comments I tend to agree with you.
Currently trying to upgrade to Android 6.0 and see if that will solve the issue.

1 Like

Yes, will definitely give this a try.

I tried your suggestions but with no luck.
Now trying to update the android firmware instead.

Whatbrowser are you using? I had trounle using chrome at first but thebuilt in browser connected.

The browser is called: Internet… (version 4.2.2-P3110XXDNE1) I do not make this up. Unfortunately it will not go past loading sign while trying to open, it does not open the WebUI. While using chrome the WebUI will open but than it will not connect to the board (status as picture in my initial post).

In the maintime I tried to update the android 4.2.2. to a higher version but without any luck. I browsed the internet but unfortunately the tablet is unable to open in TWRP to update the firmware.

Tried but no luck so far. Thanks for the suggestion

I tried using an old iPad and had the same issue and it was an I;ad so old I couldn’t download a newer browser.

Isn’t planned obsolescence wonderful.

Shoot I would really like to figure out what firmware versions we need on android and ios for this to work.

As a point of reference for Android, the current version of Google Chrome works on Android 10 or higher. Current version is 14. From the support page, sounds like there is a version for 8 or higher.

Seems to me if you’re running something older than that, you’re going to need to be adventurous.

1 Like

Thanks, that helps. I should update the docs.


Decided to admit defeat and help capitalism a bit by going for something more recent.
This system is indeed aging,

Thanks for thinking along.

Please let us know what you end up with. I’ve got a couple of nexus 7’s that need replaced, ideally with something cheap and disposable. I was running a newer tablet but I broke the screen. Can’t have nice things in the workshop!